View Issue Details

IDProjectCategoryView StatusLast Update
0005650OXID eShop (all versions)1.03. Basket, checkout processpublic2015-11-05 17:32
ReporterEgoist 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.10 / 5.0.10 
Target Version4.9.6 / 5.2.6Fixed in Version4.9.6 / 5.2.6 
Summary0005650: Wrong shippingcost calculation
DescriptionThe amountcalculation for the shippingcost is wrong (oxdelivery->isForBasket the amount-variable)
Steps To ReproduceIn my case there are different shippingrules. For example one rule is for a cartprice from 0 - 200 euro and one rule is for a cartprice from 200 - 9999 euro. These two rules are assigned to all possible article-categories. If i put one article with a price of 101,00 euro to my cart, which is assigned to two categories, then the second rule (200 - 9999 euro) is used.
Additional InformationI debug this issue and get that the amount-variable would be increased by every assigned category, which is also assigned to a shippingrule. This calculation was changed with the update to version 4.7.10 and still was an issue some versions before https://bugs.oxid-esales.com/view.php?id=4730. There is also a forum thread for this issue http://forum.oxid-esales.com/showthread.php?t=22119.
TagsNo tags attached.
ThemeAll
BrowserAll
PHP Version5.4
MySQL Version5.1

Relationships

duplicate of 0006015 closedjurate.baseviciene wrong shipping cost calculation if a product is in multiple categories 
related to 0004730 resolvedLinas Kukulskis Orderrules with Quantity -> Items would be count double 
has duplicate 0005645 closedQA Delivery Costs failed 
has duplicate 0005670 closedjurate.baseviciene Shipping cost after chaning are set false / 4.8.3. with azure 

Activities

Egoist

2014-02-12 09:28

reporter   ~0009493

this issue assigned to https://bugs.oxid-esales.com/view.php?id=5645

Egoist

2014-02-12 09:33

reporter   ~0009494

Some more additional informations: I was checking this issue with the demo shop. that means that the version 4.8.3 is also affected.

i was setting up two shippingrules with condition price, which only works one time per cart and i do not set the hook for "do not calculate more rules after this". also i assigned all articles-categories to this rules. than i choose one article and assign this article to two different categories. In this case the calculation is wrong.

martinwegele

2014-02-20 16:02

reporter   ~0009557

Last edited: 2014-02-20 16:02

View 2 revisions

What happens if you assign the articles instead of the categories? Does it work then?

svetlana

2014-02-21 08:26

reporter   ~0009564

Reminder sent to: Egoist

Hi,

if you want to have two shipping rules in shop, which depends from the total of the basket, you don't need assigned all categories or all product to these shopping cost rules at all. If there are not assigned any categories or any product to the shipping cost rule it meant that this shipping cost rule affects all categories and all products in the shop. More examples how to set up shipping rules you can find here: http://www.oxid-esales.com/en/support-services/documentation-and-help/archive-oxid-eshop/administer-eshop/set-shipping/shipping-basics.html

svetlana

2014-02-21 08:40

reporter   ~0009566

This bug is confirmed, because we have missing documentation. There need to document clear rules how to set up shipping cost rules to avoid confusion here.

Egoist

2014-02-21 08:43

reporter   ~0009567

Last edited: 2014-02-21 08:46

View 3 revisions

In the first test, there was no shippingrule affects the basket, when no category was assigned. But the main problem is not to set up shipping costs, the main problem is, that the current settings work with version 4.7.8 and with version 4.7.10 the settings do not work any more. My solution was to write a own modul with the shown code in the forum http://forum.oxid-esales.com/showthread.php?t=22119 this is the affected part of the code in the update like written before. But i do not know, if this works in all cases...

leofonic

2014-03-13 11:29

reporter   ~0009646

"This bug is confirmed, because we have missing documentation."
This is not just missing documentation, this is a bug. Of course this can be avoided by not assigning categories, but behaviour is still wrong in case categories are assigned.

jurate.baseviciene

2014-09-05 08:25

reporter   ~0010130

Last edited: 2014-12-03 09:13

View 5 revisions

There is a bug, no missing documentation.
Test case how need reproduce it:
Need to create 1 product with the price 101 eur.
Assign the product to categories Kites and Jeans;

Create 3 shipping roles:
1. Roles:
Condition : 0-200
Price: 10 abs
Assign this role to the categories Kites and Jeans;

2. Roles:
Condition : 200-9999
Price: 100 abs
Assign this role to the categories Kites and Jeans;

3. Roles:
Condition : 0-999999
Price: 200 abs

Go to Master settings-> Core settings-> Setting;
    Enable checkboxs:
- Enter Product Prices as Net Prices (plus VAT)
- Show net prices in frontend (B2B)
These check-box need enable that in frondent would be the price equal to 101 eur.

Go to frontend add product to the basket;
Product price in the basket is 101.00eur.
Go to the 3 basket step and shipping role is used incorrect:
Shipping method price should be 10 eur instead 200. In this case the second rule (200 - 9999 euro) is used, need to fix that would be used the first role

wiedeking

2014-12-03 09:06

reporter   ~0010374

I have the same problem. And this is not a documentation bug but a severe problem:

If my product is assigned to more than one category (e.g. TOP10, XMAS, Food), the shipping costs are calculated wrong. (always the last shipping rule)
It is not an option to have the product only in one category!

martinwegele

2015-01-23 14:31

reporter   ~0010633

might also be related to 0005557

wiedeking

2015-02-20 09:36

reporter   ~0010686

Hi, This problem is still not fixed.
I am working with version 4.8.7.


This is really urgent, because my customer get wrong shipping costs!

wiedeking

2015-06-09 12:34

reporter   ~0011017

I undid the change from 2013 and now it works for me again:

https://github.com/OXID-eSales/oxideshop_ce/commit/0f9ae806b29eed97edf07c3257bbceaa55c1bbd2

what this makes with the original bug, i have no clue and i do no care, because i do not have it (Deliverycost with quantity 0004730 )