View Issue Details

IDProjectCategoryView StatusLast Update
0005557OXID eShop (all versions)2.2. Shop settingspublic2014-01-07 10:00
Reportersimon_stark 
PriorityhighSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.4 / 5.0.4 revision 57063 
Target Version4.7.10 / 5.0.10Fixed in Version 
Summary0005557: delivery cost calculation doesn't work correctly when Categories are assigned
DescriptionThis is going to be a long one...

When there's a mixture of Delivery Cost Rules with different types of conditions, delivery cost calculation is starting top act up.

See "Steps to reproduce" below:
Steps To ReproduceConfigure the following set of Delivery Cost Rules (all attached to one shipping method):

------------------------------------
Test 3:

Order of Rule Processing: 1
Condition: Weight, 56 - 999999999

Once per Cart

Don't calculate further Rules if this Rule matches -> active

Assigned to Category A

------------------------------------
Test 2:

Order of Rule Processing: 2
Condition: Weight, 28 - 55.99

Once per Cart

Don't calculate further Rules if this Rule matches -> active

Assigned to Category A

------------------------------------
Test 1:

Order of Rule Processing: 3
Condition: Weight, 0 - 27.99

Once per Cart

Don't calculate further Rules if this Rule matches -> active

Assigned to Category A

------------------------------------
Standard:

Order of Rule Processing: 4
Condition: Amount, 0 - 999999

Once per Cart

Don't calculate further Rules if this Rule matches -> active

Assigned to Category B
------------------------------------

If you put either Articles from Category A or Category B in your Basket, everything seems to be okay. When you put Articles from Category A AND Category B into your basket, the calculation is not working correctly anymore.

Strangely enough, everything is fine if you work with direct assignment of articles to the Delivery Cost Rules.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0004730 resolvedLinas Kukulskis Orderrules with Quantity -> Items would be count double 

Activities

martinwegele

2013-12-09 12:32

reporter   ~0009347

Last edited: 2013-12-09 12:47

View 3 revisions

I reproduced it in a local installation. For me the delivery cost calculations differed depending on the sequence of the products in the basket!
If I put an article from category A first, which should get the price of test 1, and next was a product from category B (which should have the price of Standard) I ended up with delivery costs for rule Test 2!

This sounds like an old issue: http://forum.oxid-esales.com/showthread.php?t=7626
This one sounds similar, is newer, but there is a feedback missing: http://forum.oxid-esales.com/showthread.php?t=19914

martinwegele

2013-12-10 11:10

reporter   ~0009348

It seems that the behaviour is at least related to 0004730 because with the fix it works as expected (at least in my testing scenario): https://github.com/OXID-eSales/oxideshop_ce/commit/78b9689d8354526e5657facfc62465a53bb593fb

jurate.baseviciene

2014-01-07 10:00

reporter   ~0009383

Bug was fixed with other changes related with bug 0004730.