View Issue Details

IDProjectCategoryView StatusLast Update
0006015OXID eShop (all versions)1.03. Basket, checkout processpublic2015-01-13 16:26
Reportermartinwegele 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.9.2 / 5.2.2 
Target VersionFixed in Version 
Summary0006015: wrong shipping cost calculation if a product is in multiple categories
DescriptionIf a product is assigned to two categories at the same time and you assign these two categories to the shipping cost rules the wrong shipping cost rule is applied.

Also it's weird that the quantity influences which shipping cost rule is applied although it should only check the price.
Steps To ReproduceAssign a product (e.g. number 3503) to another category (e.g. Fashion)
You should have two shipping cost rules: One that should match (e.g. because of the price) and another that doesn't (in the demoshop you could use the first two).
Now assign some categories to these two shipping cost rules including the two that contain the product.
Add the product to your cart/basket.
Check the shipping costs with one and with two as quantity. They will be different although they should not.

Now unassign all categories and check the shipping costs again with one or with two as quantity.
Additional InformationMight be related to 0005650.
TagsNo tags attached.
ThemeAll
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

has duplicate 0005650 resolvedHR Wrong shippingcost calculation 

Activities

There are no notes attached to this issue.