View Issue Details

IDProjectCategoryView StatusLast Update
0005670OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2014-03-20 08:26
ReporterPsychotica 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.8.3 / 5.1.3 
Target VersionFixed in Version 
Summary0005670: Shipping cost after chaning are set false / 4.8.3. with azure
DescriptionOn my shop the default shipping costs are 4,50 Eur under 50 Eur orders. Over 50 Eur order the shipping is free.

If someone put items under 50 eur into basket and order them the shippings costs are correct. If someone puts items over 50 euro into basket and order without changing the items the costs are correct too.

But if someone put into basket first over 50 eur items and change later under amount of 50 eur the shipping costs are not recalculated .. the customer get free shipping. I think its missing a function that every changing in basket refresh the shipping costs.
TagsDocumentation
ThemeAzure
BrowserFireFox
PHP Version5.4
MySQL Version5.5

Relationships

duplicate of 0005650 resolvedHR Wrong shippingcost calculation 

Activities

jurate.baseviciene

2014-03-04 09:38

reporter   ~0009603

Reminder sent to: Psychotica

Hi,

Thanks a lot for submitting this issue, but unfortunately we can not reproduce this issue.
Could you please let us know if you still experience same problem on our demoshop:
http://demoshop.oxid-esales.com/EnEd/ [^]
http://demoshop.oxid-esales.com/professional-edition/ [^]
http://demoshop.oxid-esales.com/community-edition/ [^] ?
maybe you could send us more details about it?

Step how we try to reproduce from our side:

Create shipping cost are (4.5eur. - 50 eur) price is set 100 eur.
Create second shipping cost (51 eur. 99999eur.) the shipping is free
First of all we put into basket over 50 eur. items then the shipping is free
If we change items under amount of 50 eur. the shipping costs are recalculated the costumer get 100eur.

Best regards,

Psychotica

2014-03-04 14:02

reporter   ~0009605

At this time i saw, that the error is in the calculating of the shipping cost. I set the free shipping over 50 EUR. But the shop give free shipping on around 25 Eur. I dont know why. The settings are correct. A second shop of mine - the supplier shop have the problem, too. The free shipping on supplier shop is 250 Eur. But the shop give free to customer around 150 Eur. I don´t know what to do.
I havent change something about shipping cost in the files. Only set in admin.
For tests you can see my shop on the URL: http://www.g-glow.de

Which file is the "shipping-calcualting-file"?

Update to 4.8.4. was not helpfull.

leofonic

2014-03-05 15:48

reporter   ~0009609

This is probably related to bug 0005650, if you assign categories to a rule (in your case free shipping rule) and an article belongs to more than one of the assigned categories, its value is added multiple times.

Reproduce in demoshop:
1. Assign all categories to rule "Shipping costs for Standard: Free shipping for orders over $80"
2. Assign 2 categories to "Transport container BARREL"
3. Put Barrel in Basket and change quantity, you get free shipping if you buy 2, but 80€ is not yet reached

jurate.baseviciene

2014-03-10 13:07

reporter   ~0009627

Reminder sent to: Psychotica

Hi,

This case we reproduced if are assigned categories for Shipping costs rules. If you want to have two shipping rules in shop, which depends from the total of the basket, you don't need assigned all categories or all product to these shopping cost rules at all. If there are not assigned any categories or any product to the shipping cost rule it meant that this shipping cost rule affects all categories and all products in the shop. More examples how to set up shipping rules you can find here: http://www.oxid-esales.com/en/support-services/documentation-and-help/archive-oxid-eshop/administer-eshop/set-shipping/shipping-basics.html [^].

Best regards,

jurate.baseviciene

2014-03-20 08:26

reporter   ~0009664

Last edited: 2015-02-23 11:31

View 3 revisions

Closed as duplicate of 0005650