View Issue Details

IDProjectCategoryView StatusLast Update
0005645OXID eShop (all versions)1.03. Basket, checkout processpublic2015-07-01 15:29
Reporterntschigor 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.8.3 / 5.1.3 
Target VersionFixed in Version 
Summary0005645: Delivery Costs failed
DescriptionIf you have allocated a category in delivery set and the article is in more categories, the delivery calculate repeatedly.
Steps To ReproduceShow in oxdelivery::isForBasket()

foreach ( $aDeliveryCategories as $sCatId ) {

                        if ( $oProduct->inCategory( $sCatId ) ) {
                            $blUse = true;
                            $iArtAmount = $this->getDeliveryAmount( $oContent );
                            if ( $this->oxdelivery__oxfixed->value > 0 ) {
                                if ( $this->_isForArticle( $oContent, $iArtAmount ) ) {
                                    $blForBasket = true;
                                }
                            }
                            if (!$blForBasket) {
                                $iAmount += $iArtAmount;
                            }
                        }
                    }
TagsNo tags attached.
ThemeAll
BrowserAll
PHP VersionNot defined
MySQL VersionNot defined

Relationships

duplicate of 0005650 resolvedHR Wrong shippingcost calculation 
related to 0004730 resolvedLinas Kukulskis Orderrules with Quantity -> Items would be count double 
related to 0006077 closedQA delivery costs doubled 

Activities

martinwegele

2014-02-10 09:52

reporter   ~0009484

This change was the fix for bug 0004730: https://github.com/OXID-eSales/oxideshop_ce/commit/0f9ae806b29eed97edf07c3257bbceaa55c1bbd2
Was already reported in the Community Forums: http://forum.oxid-esales.com/showthread.php?p=139373#post139287

martinwegele

2014-02-10 09:56

reporter   ~0009485

Maybe this is also related? http://forum.oxid-esales.com/showthread.php?t=22190

ntschigor

2014-02-10 20:07

reporter   ~0009488

Last edited: 2014-02-10 20:08

View 2 revisions

Yes, it is same one. Thanks.

jurate.baseviciene

2014-02-11 12:41

reporter   ~0009490

Reminder sent to: ntschigor

Hi,

Thanks a lot for submitting this issue, but unfortunately we can not reproduce this issue. Maybe you could send us more details about it? What price do you want setup?

Best regards,

ntschigor

2014-02-11 13:44

reporter   ~0009491

Look at this post: https://bugs.oxid-esales.com/view.php?id=5645#c9484

martinwegele

2014-02-20 15:59

reporter   ~0009556

A customer reported a similar behaviour which occurs since he patched his shop from 4.8.1 to 4.8.3. Workaround: Do not use category assignments but assign all articles.

svetlana

2014-02-21 10:14

reporter   ~0009573

This is affect after 0004730 bug was fixed, So we will add additional info for developer in http://wiki.oxidforge.org/Downloads/4.7.10_5.0.10