View Issue Details

IDProjectCategoryView StatusLast Update
0005349OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2014-03-04 11:29
Reporterwiedeking 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.5 / 5.0.5 
Target Version4.7.10 / 5.0.10Fixed in Version4.7.10 / 5.0.10 
Summary0005349: last scale price is empty, when discount is available
Descriptionhi,

i reproduced this in a new demo store.

If you have scale price (1 item = 1€, 2-5 items = 4€, 6-99 items=3€, all prices are shown in the product detail page under the little arrow. This works fine.

If you now add any discount (10% on all items), all discounts for the product and the first scale prices are calculated correctly, BUT from the 2nd scale price, it is just empty.
Steps To Reproduce1.) add at least 2 scale prices to any product.
2.) add a global discount (10% on everything)
3.) take a look at the product detail page.
TagsScale Price
ThemeAzure
BrowserAll
PHP Version5.4
MySQL Versionany

Relationships

duplicate of 0005229 closedjurate.baseviciene AmountPriceInfo breaks on articlediscounts 
has duplicate 0005489 closedjurate.baseviciene Artcle discount makes last amount price not visible 
has duplicate 0005540 resolvedjurate.baseviciene with the use of global discounts, only one scale price is displayed 
has duplicate 0005552 resolvedLinas Kukulskis Block price error: on second and more price $priceItem->fbrutprice is null 

Activities

wiedeking

2013-08-20 16:00

reporter  

scale-price-bug.jpg (21,267 bytes)
scale-price-bug.jpg (21,267 bytes)

wiedeking

2013-10-30 17:06

reporter   ~0009201

Last edited: 2013-10-31 10:30

View 2 revisions

this is also duplicate.


The solution suggested in 0005229 is working!

release

2013-11-18 11:07

administrator   ~0009275

Issue was fixed.

martinwegele

2013-12-11 15:55

reporter   ~0009355

https://github.com/OXID-eSales/oxideshop_ce/commit/af48b8440c618d85b944020c80e736f03fd40743