View Issue Details

IDProjectCategoryView StatusLast Update
0004528OXID eShop (all versions)2. ----- eShop backend (admin) -----public2013-01-14 09:18
Reporterleofonic 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version4.6.6 revision 54646 
Summary0004528: Price of main article is hidden when "Parent Products can be purchased" is off
DescriptionWhen "Parent Products can be purchased" is off, price of main article is hidden in backend. This is not OK, because this price is inherited to variants, so it is an active price that is used in frontend.

This has been reported in 0002912 and 0003994, where the solution was to edit the help field, which does not resolve the issue.
Steps To ReproduceIn demoshop, set all prices of all variants of shirt kisser fish to zero. Look at frontend, price of all variants is now 59.90. This price cannot be seen or edited in backend.
TagsVariants
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0004089 resolvedaurimas.gladutis Missing price of father in detailview of variants, basic template 

Activities

marco_steinhaeuser

2013-01-05 13:57

administrator   ~0008217

See Ray's comment to a possible fix. I think that sounds really useful for a final resolution.

ray

2013-01-05 14:05

reporter   ~0008218

Last edited: 2013-01-05 14:07

View 2 revisions

As the fathers price is used for a bunch of functions throughout the shop, I think it would be better to show this field as "readonly" in admin if a value is present. It causes a lot of unnecessary time to figure out what´s wrong, if you can not see the field at all. Describe in help-text how to set the field editable again to change / delete the value (set to "purchasable").
Showing this information (price of father / if set) at the variants administration would be helpful as well.

leofonic

2013-01-05 22:30

reporter   ~0008219

@ray: why readonly, what's wrong with the current solution? Right now it is editable any time, which is fine, to make it readonly so you would have to switch to "parent is buyable" again to edit would be a change for the worse imho.

ray

2013-01-07 11:21

reporter   ~0008226

well - apparently I missed this last change to "editable anytime"

anyway I would prefer to set the field to "readonly" if parent item is set to "not purchaseable" - just to point out the different setting

leofonic

2013-01-07 11:32

reporter   ~0008227

OK maybe some additional helptext/warning could show this, but having to switch to "parent is buyable" again is not an option imho, because it's the behaviour this entry is supposed to resolve.

aurimas.gladutis

2013-01-14 09:18

reporter   ~0008254

Error message added when parent product is not buyable.