View Issue Details

IDProjectCategoryView StatusLast Update
0004089OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2013-01-02 12:36
Reporterllui 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.11 revision 46050 
Target Version4.5.12 revision 52682Fixed in Version4.5.12 revision 52682 
Summary0004089: Missing price of father in detailview of variants, basic template
DescriptionThe box variantslist in detail view of one variant, doesn't display the price for the father article.

Pressing "to basket" on the father article the right price and article is transfered to the basket.

Steps To Reproduceosxid demoshop:

- switch template to basic
- set "father article" buyable
- create some variants of one article (not multidimensional) enter a price and activate them

Go to one of the created variants in the frontend
TagsSelection List
ThemeBasic
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0004528 resolvedaurimas.gladutis Price of main article is hidden when "Parent Products can be purchased" is off 

Activities

llui

2012-05-30 23:11

reporter  

VaterVar_1.jpg (97,138 bytes)
VaterVar_1.jpg (97,138 bytes)

jurate.baseviciene

2012-06-05 13:13

reporter  

pictures.png (120,514 bytes)
pictures.png (120,514 bytes)

jurate.baseviciene

2012-06-05 13:20

reporter   ~0006773

Reminder sent to: llui

Sorry, but I can not reproduce the case neither in 4.5 nor in eShop 4.6.0 versions.
if selected variant is active and buyable(Parent" Products can be purchased), I got results please see in pictures.png.
could you please let us know if you still experience same problem on our latest eShop version 4.6 or demoshop:
http://demoshop.oxid-esales.com/enterprise-edition/
http://demoshop.oxid-esales.com/professional-edition/
http://demoshop.oxid-esales.com/community-edition/ ?
Maybe some other special options are turned on?

llui

2012-06-05 17:01

reporter  

oxid_2.jpg (84,478 bytes)
oxid_2.jpg (84,478 bytes)

llui

2012-06-05 17:08

reporter   ~0006784

Yes, the problem is still present.
I have tested as mentioned above in the current demoshop 4.6.1_45706 (10 minutes ago) and made a snapshot.

The changes I have made:
1. set the option "Parent Producs can be purchased"
2. create some variants

http://demoshop.oxid-esales.com/community-edition

leofonic

2012-06-11 15:10

reporter   ~0006853

The file pictures.png shows only variants in the list, you have to show the father in the list by doing this: "Go to one of the created variants in the frontend" to reproduce the bug.

r.victor

2012-08-22 13:29

reporter   ~0007355

Confirm the bug in EE version 4.6.3_47975. This problem is not just the main price (getFPrice) but also scale prices (loadAmountPriceInfo).

Dear llui,
can you please change this bug priority of urgent.

r.victor

2012-09-24 10:06

reporter   ~0007476

Dear OXID Developer,

could you fix this critical bug immediately?
We can not update our shop just because this missing main features.

llui

2012-09-24 18:09

reporter   ~0007482

Hello r.victor,

i can't change the priority of this bug, maybe an admin?

tomas_liubinas

2012-10-02 11:37

reporter   ~0007524

Last edited: 2012-10-02 11:39

View 3 revisions

To whom is going to fix this. I had a quick glance and the reason causing this problem is in oxarticle.php class line about 4048:
self::$_aLoadedParents[$sIndex]->_blLoadPrice = false;

This line is wrong and should be removed. This is preliminar information, further investigation if the fix is sufficient is required.

dainius.bigelis

2012-10-04 05:06

reporter   ~0007546

The same issue exists also in 4.5.11 version eShop.
@Developers: please check in details - if the fix does not need template changes - then fix also in 4.5 version (then move to 4.6 as well).