View Issue Details

IDProjectCategoryView StatusLast Update
0003994OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2012-12-07 14:27
ReporterBob Byte 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version4.6.0 revision 44406 
Target VersionFixed in Version 
Summary0003994: Price disappears after inserting
DescriptionPrice box disappears after inserting attributes from a selective list.
Steps To ReproduceThat is the problem:

you make a new article with price,manufacterer an so on. After you are importing a select list as variants and turn back to the first tab all prices boxes are gone.
Additional InformationPlease see attached picture
TagsProducts
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0002912 resolvedjuergen_busch Parent-product price is not editable and inheritable but amount prices are 

Activities

Bob Byte

2012-05-04 12:54

reporter  

Price4.png (51,435 bytes)
Price4.png (51,435 bytes)

leofonic

2012-05-04 14:44

reporter   ~0006512

See also 0002912

michael_keiluweit

2012-05-04 15:00

developer   ~0006513

Cannot reproduce this.

If the option Core Settings -> System -> Variants -> '"Parent" Products can be purchased' isn't checked, the price box of the parent article will be hide. Otherwise (the checkbox is activ) the price box is there.

leofonic

2012-05-05 22:25

reporter   ~0006514

> If the option Core Settings -> System -> Variants -> '"Parent" Products can be purchased' isn't checked, the price box of the parent article will be hide.

Well IMO, this is exactly the problem: This price is inhertited to variants (if price of variant is set to zero), so it is an active price that can be seen in frontend, why is it hidden in Backend then?

Imagine, you have an article that costs 50$. Now you create variants, all price set to zero. In frontend each of the variants now has price 50$. In Backend this price cannot be seen at all anymore.

Now if you want to change the price for all variants to 40$, the only way to achieve this is (without editing every single variant) is to set "parent is buyable" in core settings, edit the article price, and change to "parent is not buyable" back again.