View Issue Details

IDProjectCategoryView StatusLast Update
0002912OXID eShop (all versions)2. ----- eShop backend (admin) -----public2012-08-20 11:40
Reportercsimon 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.0 revision 34568 
Target VersionFixed in Version 
Summary0002912: Parent-product price is not editable and inheritable but amount prices are
Descriptionsee title. The price of variant parent should be editable and inheritable as well - like the amountprices. For example if you sell t-shirts in various colors for 10 € and you only need the variants for stock management you don't have to add a price for each variant.
Also please implement Help text next to this field, which explains about behavior of the price, depending on the option "Net or Bruto price" (that in input field the price will mean Net or Bruto, depending on option, but next to this field always will be Bruto price shown), also hint about price inheritance to Variant products.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Relationships

has duplicate 0003994 resolvedsvetlana Price disappears after inserting 

Activities

dainius.bigelis

2011-12-29 14:42

reporter   ~0005564

Reminder sent to: csimon

Hi,

We checked the case, but we cannot reproduce it, better say - we reproduced vice versa behavior: that usual price is inherited from Parent product to variant products always, but the amount prices are not inherited to the variants (amount prices are valid only for Parent product, if inserted for parent product only).
Can you tell more details in which cases you reproduce such behavior? maybe it depends on some specific options for product prices, or maybe you have some customizations in eshop (or modules installed), which might affect the price inheritance.
Please tell us more details and we will continue debuging if this case.

leofonic

2011-12-29 15:54

reporter   ~0005566

But because usual price is inheritable, it should also be editable without having to switch on "parent is buyable".

dainius.bigelis

2011-12-30 09:54

reporter   ~0005568

Reminder sent to: csimon, leofonic

Could you describe what you mean "should be editible"?
In current situation you can define any custom price for variant products. Principle is like - if variant product have no own price, then it inherits price from Parent product. If you insert any price for Variant - then it has own price (Parent price then is not inherited).
The price of Parent product also you can edit anytime. So sorry, but I don't get the point when and where you want this price to be editable. Please tell exactly the case what you expect and where, because probably I missunderstood the user case.

leofonic

2011-12-30 11:02

reporter   ~0005569

If option "Parent Products can be purchased" is turned off in "core settings/system", price of parent is not shown in the "main" tab of parent article, but nevertheless it is inherited to variants.

Bob Byte

2012-05-23 14:47

reporter   ~0006676

leofonic is right, when the price of the parent is not longer shown in the "main" tab you can't edit. You have always to turn "Parent Products can be purchased" on, edit the price and turn off of switch.

juergen_busch

2012-08-20 11:40

developer   ~0007345

Edited HELP_ARTICLE_MAIN_PRICE on July 16th 2012.