View Issue Details

IDProjectCategoryView StatusLast Update
0006445Flow themeThemepublic2017-09-07 10:01
Reporterpatchwork.de 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0.0-beta 
Target VersionFixed in Version 
Summary0006445: sorting by price doesn't work
Descriptionsee demoshop:
http://demoshop.oxid-esales.com/professional-edition/Kiteboarding/Kites/?ldtype=infogrid&_artperpage=10&listorderby=oxvarminprice&listorder=asc&pgNr=0&cl=alist&searchparam=&cnid=0f4fb00809cec9aa0910aa9c8fe36751
Steps To Reproducesee demoshop:
http://demoshop.oxid-esales.com/professional-edition/Kiteboarding/Kites/?ldtype=infogrid&_artperpage=10&listorderby=oxvarminprice&listorder=asc&pgNr=0&cl=alist&searchparam=&cnid=0f4fb00809cec9aa0910aa9c8fe36751
TagsNo tags attached.

Relationships

duplicate of 0006579 resolvedsaulius.stasiukaitis OXID eShop (all versions) Sorting by self-created fields in the oxarticles does not work 
has duplicate 0006553 closedQA OXID eShop (all versions) Sort by price (asc) sometimes does not work 
has duplicate 0006664 closed OXID eShop (all versions) Sorting by price in categories does not work 
has duplicate 0006596 closed OXID eShop (all versions) Category sort by e.g. oxartnum does not work. 
child of 0006083 resolvedanton.fedurtsya OXID eShop (all versions) article sorting fields not verified against valid field from admin settings 

Activities

QA

2016-07-11 08:06

administrator   ~0011675

I can't reproduce this case as the sorting works fine for me. See the attached screenshot whichs shows the sorting in the demoshop.
Please provide a more detailed description how the bug is reproduceable.

QA

2016-07-11 08:06

administrator  

b6445nr.png (260,664 bytes)
b6445nr.png (260,664 bytes)

juergen_busch

2016-07-11 11:27

developer   ~0011677

Sorry, but it doesn't work with Firefox and Chrome. Tested in demoshop.

QA

2016-07-11 13:08

administrator   ~0011678

Weird. I checked it again and I saw that the sorting was not accepted (bug confirmed). Later - ~1 hour - I tried it again and it worked as before.

juergen_busch

2016-07-11 13:46

developer   ~0011679

Strange. You are right. Now it works.

patchwork.de

2016-07-11 13:56

reporter   ~0011680

double-strange! clicked at about 11:30 on the link above to demoshop and in didn't work - now it works!
But not in my test-shop:
http://www.kunstundmarkt.de/Bekleidungsstoffe/Fleece/?ldtype=infogrid&_artperpage=20&listorderby=oxvarminprice&listorder=asc&pgNr=0&cl=alist&searchparam=&cnid=category_05-30

juergen_busch

2016-07-11 14:01

developer   ~0011681

Last edited: 2016-07-11 14:43

View 2 revisions

It doesn't work in my local installation too.
But after a while it works properly.