View Issue Details

IDProjectCategoryView StatusLast Update
0006664OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2017-09-04 11:48
Reporterleofonic 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.10.4 / 5.3.4 
Target VersionFixed in Version 
Summary0006664: Sorting by price in categories does not work
DescriptionSorting by price in categories does not work
Steps To ReproduceGo to http://demoshop.oxid-esales.com/community-edition/Kiteboarding/Kites/
Sort by price
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
Database VersionNot defined

Relationships

duplicate of 0006579 resolvedsaulius.stasiukaitis OXID eShop (all versions) Sorting by self-created fields in the oxarticles does not work 
duplicate of 0006445 resolvedsaulius.stasiukaitis Flow theme sorting by price doesn't work 

Activities

QA

2017-07-13 15:06

administrator   ~0012180

The default settings are sorted by oxvarminprice.
Sorting according to oxprice (under Settings => Articles) works if entered (see Attachment).

QA

2017-07-13 15:06

administrator  

oxprice.PNG (25,231 bytes)
oxprice.PNG (25,231 bytes)

leofonic

2017-07-13 15:10

reporter   ~0012181

Sorting by oxvarminprice does not work.

QA

2017-07-14 09:00

administrator   ~0012182

If in the shopadmin oxvarminprice is registered instead of oxprice, then is sorted according to the minimal variant price of the article.
This also works.

See in demoshop
http://demoshop.oxid-esales.com/professional-edition/Bekleidung/Fashion/Fuer-Sie/Jeans/

Bekleidung -> Fashion -> Für Sie -> Jeans

leofonic

2017-07-14 15:13

reporter   ~0012183

No this does not always work, problem is with oxNew('oxArticle')->getFieldNames() in oxubase::getUserSelectedSorting(), which depends on cached value and oxvarminprice is not always present in field list.

Just empty tmp or wait until demoshop is reset and click on the supplied link.
https://www.youtube.com/watch?v=xMHuABnfWA4&feature=youtu.be&hd=1

QA

2017-07-14 15:33

administrator   ~0012184

This Bug is already reported in https://bugs.oxid-esales.com/view.php?id=6579