View Issue Details

IDProjectCategoryView StatusLast Update
0006164OXID eShop (all versions)4.01. Database handlingpublic2018-10-19 12:25
Reporterbjoerk 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version4.9.3 / 5.2.3 
Target VersionFixed in Version6.0.2 
Summary0006164: max size of BLOB for oxconfig.oxvarvalue can be exceeded
DescriptionHaving a highly modifyed EE with a huge amount of extensions the maximum size 64KB for the datatype BLOB auf oxconfig.oxvarvalue can be exceeded.
This leads into a complete breakdown of the OXID module system and the shop goes offline because there is no check if the max size of oxvarvalue will be exceeded when adding new entries.
Reaching the maximum of 64KB the data of oxvarvalue is truncated at the maximum byte which leads into an incomplete serealized array and the shop will stop working.
Changing to MEDIUMBLOB and reinstalling all modules solves the problem.
At least for Enterprise Edition this should be default and all editions should get a check to avoid running into this problem.
Additional Information0005948 was closed without changes and the note that this case is unusual.
Assuming that most EE will be highly modified this should be deemed as a usual use case.
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionAll
MySQL VersionNot defined

Relationships

related to 0005549 resolvedsaulius.stasiukaitis module-name and value-name of module-settings limited by oxmodule-/oxvarname-field-length 
related to 0006090 confirmed Field oxtplblocks.oxmodule is too short 
has duplicate 0005948 closedLinas Kukulskis DB : column type BLOB for oxconfig.oxvarvalue is not sufficient in some productive scenarios 

Activities

QA

2015-06-11 14:57

administrator   ~0011028

While possible, there is no known impact of this issue until now.

Though, it would make sense to extend said BLOB field to MEDIUMBLOB in future releases to play it safe.

IMHO this is a (valid) feature request.

d3

2015-11-26 14:27

reporter   ~0011330

We have got the same problem...

IMHO it's a bug. There are no communicated module limitations. In our case (ca. 80 modules) this "feature request" crashes the shop.

DS

FibreFoX

2015-11-26 15:31

reporter   ~0011333

This is a bug, clearly, because the shop just does not validate length of the content its going to put into the database. Same "just a feature"-feeling like when hitting https://bugs.oxid-esales.com/view.php?id=5549

nothing documented, but working (maybe not as wished) -> feature or bug
nothing documented, and breaking the shop -> bug

keywan.ghadami

2016-05-20 14:51

developer   ~0011596

having the same problem using MEDIUMBLOB helped

d3

2018-02-28 17:18

reporter   ~0012404

same problem again, pull request for current shop version: https://github.com/OXID-eSales/oxideshop_ce/pull/633

FibreFoX

2018-03-01 12:34

reporter   ~0012405

Maybe instead of pushing the limit this should result in some technical redesign. In the meantime there should be limitation-checks which get reported into the logfiles, or even not being able to activate such modules.

anton.fedurtsya

2018-03-01 16:08

manager   ~0012406

Thanks, the Pull request 633 was merged to 6.x and master.