View Issue Details

IDProjectCategoryView StatusLast Update
0005549OXID eShop (all versions)2.3. Extensions (modules, themes)public2014-04-10 16:24
ReporterFibreFoX 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.1 / 5.1.1 
Target Version4.8.5 / 5.1.5Fixed in Version4.9.0_5.2.0_beta1 
Summary0005549: module-name and value-name of module-settings limited by oxmodule-/oxvarname-field-length
DescriptionThe oxconfig-table has restrictions regarding the field-length of "oxmodule" and "oxvarname". It should be documented somewhere for developers, that they may shorten their configuration-names.

I think there is a problem especially with the "oxmodule"-field, because i can't find any documentation about restrictions for the ID in the module-metadata-file.

At least, please, add that information to the docu, EVEN BETTER increase this field-length too.
Additional InformationWhile developing a module, i got a strange "error" that my module-settings didn't got stored, my bool with a 34-char value-name never got stored ... which made me crazy looking for non-existing bugs in my code.

I finally got a clue after using the "ac_module_internals"-module (where i could see that the stored one was not the whole string).
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0006090 confirmed Field oxtplblocks.oxmodule is too short 
related to 0006164 resolvedanton.fedurtsya max size of BLOB for oxconfig.oxvarvalue can be exceeded 

Activities

saulius.stasiukaitis

2014-02-18 16:10

reporter   ~0009518

Module name and module value fields in oxConfig table increased to 100.
Module name can hold up to 93 symbols as we add "module:" before module name.
Module value can hold up to 100 symbols.