View Issue Details

IDProjectCategoryView StatusLast Update
0005770module PayPalmodule PayPal - subpublic2014-05-29 09:40
Reportercephir 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0005770: Paypal Error
Descriptionif product quantity is not integer paypal module reports an error

this is may be related to
https://bugs.oxid-esales.com/view.php?id=5257
https://bugs.oxid-esales.com/view.php?id=5394
Steps To ReproduceOXID CE 4.7.8
PayPal Modul 3.0.2

Shop Settings >> Orders >> Nicht ganzzahlige Eingaben bei Artikelmengen erlauben (z.B. 1,5)

Module Settings >> Paypal >> Warenkorb auf PayPal-Zahlungsseite >> Warenkorb bei PayPal anzeigen

Add any non integer quantity to cart (see attached image for example)
Additional Information======================= Request to PayPal [2014-05-20 17:47:07] ======================= #

SESS ID: o5qme2b3ao8273k66ev16g41q0
array (
  'VERSION' => '84.0',
  'CALLBACKVERSION' => '84.0',
  'LOCALECODE' => 'de_DE',
  'SOLUTIONTYPE' => 'Mark',
  'CARTBORDERCOLOR' => '2b8da4',
  'PAYMENTREQUEST_0_PAYMENTACTION' => 'Authorization',
  'NOSHIPPING' => '0',
  'PAYMENTREQUEST_0_TAXAMT' => '26.42',
  'PAYMENTREQUEST_0_AMT' => '176.78',
  'PAYMENTREQUEST_0_CURRENCYCODE' => 'EUR',
  'PAYMENTREQUEST_0_ITEMAMT' => '139.05',
  'PAYMENTREQUEST_0_SHIPPINGAMT' => '11.31',
  'PAYMENTREQUEST_0_SHIPDISCAMT' => '0.00',
  'L_SHIPPINGOPTIONISDEFAULT0' => 'true',
  'L_SHIPPINGOPTIONNAME0' => 'Standardversand',
  'L_SHIPPINGOPTIONAMOUNT0' => '11.31',
  'PAYMENTREQUEST_0_DESC' => 'Ihre Bestellung bei Testshop GmbH in Höhe von 176,78 EUR',
  'PAYMENTREQUEST_0_CUSTOM' => 'Ihre Bestellung bei Testshop GmbH in Höhe von 176,78 EUR',
  'ADDROVERRIDE' => '1',
  'MAXAMT' => '177.78',
  'L_PAYMENTREQUEST_0_NAME0' => 'testprodukt dark matt blue',
  'L_PAYMENTREQUEST_0_AMT0' => '55.62',
  'L_PAYMENTREQUEST_0_QTY0' => '2.5',
  'L_PAYMENTREQUEST_0_ITEMURL0' => 'http://testshop/Alle-Artikel/testprodukt.html?force_sid=o5qme2b3ao8273k66ev16g41q0&',
  'L_PAYMENTREQUEST_0_NUMBER0' => '096-442',
  'PAYMENTREQUEST_0_SHIPTONAME' => 'John Doe',
  'PAYMENTREQUEST_0_SHIPTOSTREET' => 'Maple Street 2425',
  'PAYMENTREQUEST_0_SHIPTOCITY' => 'Any City',
  'PAYMENTREQUEST_0_SHIPTOZIP' => '9041',
  'PAYMENTREQUEST_0_SHIPTOPHONENUM' => '217-8918712',
  'PAYMENTREQUEST_0_SHIPTOCOUNTRYCODE' => 'DE',
  'METHOD' => 'SetExpressCheckout',
)

======================= Response from PayPal [2014-05-20 17:47:09] ======================= #

SESS ID: o5qme2b3ao8273k66ev16g41q0
array (
  'TIMESTAMP' => '2014-05-20T15:47:09Z',
  'CORRELATIONID' => '5487fef9e81ee',
  'ACK' => 'Failure',
  'VERSION' => '84.0',
  'BUILD' => '11024577',
  'L_ERRORCODE0' => '10413',
  'L_SHORTMESSAGE0' => 'Transaction refused because of an invalid argument. See additional error messages for details.',
  'L_LONGMESSAGE0' => 'The totals of the cart item amounts do not match order amounts.',
  'L_SEVERITYCODE0' => 'Error',
)
TagsNo tags attached.

Relationships

duplicate of 0005726 resolvedaurimas.gladutis PayPal Extension throws error message "The totals of the cart item amounts do not match order amounts" 

Activities

cephir

2014-05-20 18:35

reporter  

cephir

2014-05-20 18:37

reporter   ~0009917

if "Warenkorb bei PayPal anzeigen" is disabled everything works fine