View Issue Details

IDProjectCategoryView StatusLast Update
0005257module PayPalmodule PayPal - subpublic2014-03-04 11:29
Reportereike_spriess 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2.1.1 
Summary0005257: PayPal Error: The totals of the cart item amounts do not match order amounts.
DescriptionIf Shopconfiguration is like in "Setps to Reproduce" described, and have an article in basket with calculated discount and you are selecting PayPal as Payment Method, you get the PayPal Error Message:

"The totals of the cart item amounts do not match order amounts."
Steps To ReproduceShop configuration in OXID eShop Enterprise Edition, Version 5.0.6 and PayPal Module 2.1.0 installed:

VAT Settings (see Screenshot)
Discount Settings (see Screenshot)
PayPal Error (See Screenshot)
Additional InformationPayPal Log (Request and Response) is attached.
TagsNo tags attached.

Relationships

related to 0005394 resolvedtomas.lygutas wrong calculations for PayPal when using voucher 

Activities

eike_spriess

2013-06-27 13:52

developer  

VAT_Settings.JPG (115,895 bytes)
VAT_Settings.JPG (115,895 bytes)

eike_spriess

2013-06-27 13:53

developer  

Discount_Settings.JPG (90,860 bytes)
Discount_Settings.JPG (90,860 bytes)

eike_spriess

2013-06-27 13:54

developer  

PayPal Error Message.JPG (100,742 bytes)
PayPal Error Message.JPG (100,742 bytes)

eike_spriess

2013-06-27 13:54

developer  

Paypal_log.txt (2,385 bytes)
======================= REQUEST TO PAYPAL [2013-06-27 13:25:39] ======================= #

SESS ID: f7517a7f9446ee186ebb027eee10e1c9
array (
  'VERSION' => '84.0',
  'PWD' => '1353676054',
  'USER' => 'suppor_1353676031_biz_api1.oxid-esales.com',
  'SIGNATURE' => 'AyCukjHuPEF23Moc.H9wGKZKviIEAmU2pC-Mu8Yo2VWJBNgazhPtNhW1',
  'CALLBACKVERSION' => '84.0',
  'NOSHIPPING' => '2',
  'RETURNURL' => 'http://support.oxid-esales.com/development/eike/index.php?lang=0&sid=f7517a7f9446ee186ebb027eee10e1c9&rtoken=db5c41ef&shp=1&cl=oePayPalExpressCheckoutDispatcher&fnc=getExpressCheckoutDetails',
  'CANCELURL' => 'http://support.oxid-esales.com/development/eike/index.php?lang=0&sid=f7517a7f9446ee186ebb027eee10e1c9&rtoken=db5c41ef&shp=1&cl=basket',
  'LOCALECODE' => 'de_DE',
  'SOLUTIONTYPE' => 'Mark',
  'BRANDNAME' => 'eFire Testshop',
  'PAYMENTREQUEST_0_PAYMENTACTION' => 'Sale',
  'PAYMENTREQUEST_0_AMT' => '1033.23',
  'PAYMENTREQUEST_0_CURRENCYCODE' => 'EUR',
  'PAYMENTREQUEST_0_ITEMAMT' => '1056.72',
  'PAYMENTREQUEST_0_SHIPPINGAMT' => '0.00',
  'PAYMENTREQUEST_0_SHIPDISCAMT' => '-22.56',
  'PAYMENTREQUEST_0_DESC' => 'Ihre Bestellung bei OXID eShop 5 in Höhe von 1.033,23 EUR',
  'PAYMENTREQUEST_0_CUSTOM' => 'Ihre Bestellung bei OXID eShop 5 in Höhe von 1.033,23 EUR',
  'L_SHIPPINGOPTIONISDEFAULT0' => 'true',
  'L_SHIPPINGOPTIONNAME0' => 'Standard',
  'L_SHIPPINGOPTIONAMOUNT0' => '0.00',
  'CALLBACK' => 'http://support.oxid-esales.com/development/eike/index.php?lang=0&sid=f7517a7f9446ee186ebb027eee10e1c9&rtoken=db5c41ef&shp=1&cl=oePayPalExpressCheckoutDispatcher&fnc=processCallBack',
  'CALLBACKTIMEOUT' => '6',
  'MAXAMT' => '1109.28',
  'L_PAYMENTREQUEST_0_NAME0' => 'Gesamtsumme:',
  'L_PAYMENTREQUEST_0_AMT0' => '1056.72',
  'L_PAYMENTREQUEST_0_QTY0' => '1',
  'METHOD' => 'SetExpressCheckout',
)

======================= RESPONSE FROM PAYPAL [2013-06-27 13:25:41] ======================= #

SESS ID: f7517a7f9446ee186ebb027eee10e1c9
array (
  'TIMESTAMP' => '2013-06-27T11:25:40Z',
  'CORRELATIONID' => '7f1694756427c',
  'ACK' => 'Failure',
  'VERSION' => '84.0',
  'BUILD' => '6561328',
  'L_ERRORCODE0' => '10413',
  'L_SHORTMESSAGE0' => 'Transaction refused because of an invalid argument. See additional error messages for details.',
  'L_LONGMESSAGE0' => 'The totals of the cart item amounts do not match order amounts.',
  'L_SEVERITYCODE0' => 'Error',
)

Paypal_log.txt (2,385 bytes)

Adrian.Kirchner

2013-06-27 14:17

reporter   ~0008849

This is also reproducable with vouchers instead of a discount.