View Issue Details

IDProjectCategoryView StatusLast Update
0005394module PayPalmodule PayPal - subpublic2014-03-04 11:25
Reportermartinwegele 
PriorityhighSeveritycriticalReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version2.1.1 
Target VersionFixed in Version2.0.7 
Summary0005394: wrong calculations for PayPal when using voucher
DescriptionWhen using a voucher and the PayPal as a payment method in some cases it will refuse payment with this error message: "The totals of the cart item amounts do not match order amounts."
That's true because the calculations of the PayPal module are different from the ones of the basket. (See example)
667,35 - 66,73 != 600,61
Steps To Reproduce0. Install the PayPal module and activate the logging
1. In "Master Settings -> Core Settings -> Settings -> VAT" activate " Enter Product Prices as Net Prices (plus VAT) "
2. Create a product with a price of 112.16 (133.47 incl. VAT)
3. Create a coupon with a discount of 10%
4. Put 5 items of this product into the basket
5. Enter the coupon number
The cart will now look like this:
     133,47 € 19% 667,35 €
Total Products (net): 504,71 €
plus VAT 19% Amount: 95,90 €
Total Products (gross): 667,35 €
Coupon (No. test) -66,74 €
Shipping cost 0,00 €
Grand Total: 600,61 €
6. click on the express checkout button and see the error message: "The totals of the cart item amounts do not match order amounts."
Additional Information667,35 - 66,73 != 600,61

======================= REQUEST TO PAYPAL [2013-09-04 18:23:13] ======================= #

SESS ID: 4pesrqqapm24fr409k2a25oii7
array (
  'VERSION' => '84.0',
  'PWD' => 'x',
  'USER' => 'x',
  'SIGNATURE' => 'x',
  'CALLBACKVERSION' => '84.0',
  'NOSHIPPING' => '2',
  'RETURNURL' => 'http://shop/index.php?lang=0&sid=4pesrqqapm24fr409k2a25oii7&rtoken=7ac51050&shp=2&cl=oePayPalExpressCheckoutDispatcher&fnc=getExpressCheckoutDetails',
  'CANCELURL' => 'http://shop/index.php?lang=0&sid=4pesrqqapm24fr409k2a25oii7&rtoken=7ac51050&shp=2&cl=basket',
  'LOCALECODE' => 'de_DE',
  'SOLUTIONTYPE' => 'Mark',
  'BRANDNAME' => 'OXID Demoshop Professional Edition',
  'PAYMENTREQUEST_0_AMT' => '600.61',
  'PAYMENTREQUEST_0_CURRENCYCODE' => 'EUR',
  'PAYMENTREQUEST_0_ITEMAMT' => '667.35',
  'PAYMENTREQUEST_0_SHIPPINGAMT' => '0.00',
  'PAYMENTREQUEST_0_SHIPDISCAMT' => '-66.73',
  'PAYMENTREQUEST_0_DESC' => 'Ihre Bestellung bei Subshop in Höhe von 600,61 EUR',
  'PAYMENTREQUEST_0_CUSTOM' => 'Ihre Bestellung bei Subshop in Höhe von 600,61 EUR',
  'L_SHIPPINGOPTIONISDEFAULT0' => 'true',
  'L_SHIPPINGOPTIONNAME0' => '#1',
  'L_SHIPPINGOPTIONAMOUNT0' => '0.00',
  'CALLBACK' => 'http://shop/index.php?lang=0&sid=4pesrqqapm24fr409k2a25oii7&rtoken=7ac51050&shp=2&cl=oePayPalExpressCheckoutDispatcher&fnc=processCallBack',
  'CALLBACKTIMEOUT' => '6',
  'MAXAMT' => '764.09',
  'L_PAYMENTREQUEST_0_NAME0' => 'Gesamtsumme:',
  'L_PAYMENTREQUEST_0_AMT0' => '667.35',
  'L_PAYMENTREQUEST_0_QTY0' => '1',
  'METHOD' => 'SetExpressCheckout',
)

======================= RESPONSE FROM PAYPAL [2013-09-04 18:23:14] ======================= #

SESS ID: 4pesrqqapm24fr409k2a25oii7
array (
  'TIMESTAMP' => '2013-09-04T16:23:58Z',
  'CORRELATIONID' => '8e33bd63bd91f',
  'ACK' => 'Failure',
  'VERSION' => '84.0',
  'BUILD' => '7560199',
  'L_ERRORCODE0' => '10413',
  'L_SHORTMESSAGE0' => 'Transaction refused because of an invalid argument. See additional error messages for details.',
  'L_LONGMESSAGE0' => 'The totals of the cart item amounts do not match order amounts.',
  'L_SEVERITYCODE0' => 'Error',
)

TagsNo tags attached.

Relationships

related to 0005257 resolvedsaulius.stasiukaitis PayPal Error: The totals of the cart item amounts do not match order amounts. 

Activities

tomas.lygutas

2013-09-23 16:25

reporter   ~0009108

Rounding added