View Issue Details

IDProjectCategoryView StatusLast Update
0005726module PayPalmodule PayPal - subpublic2014-09-16 15:22
Reportereike_spriess 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.3 
Target Version3.2.0Fixed in Version3.2.0 
Summary0005726: PayPal Extension throws error message "The totals of the cart item amounts do not match order amounts"
DescriptionIf in OXID eFire PayPal extension in shop admin Extension -> Modules -> Settings -> Show shopping cart on PayPal site is enabled

and also

Master Settings -> Core Settings -> Settings -> Order -> Allow fraction Quantities (e.g. 1.5) is enabled

and customer wants to order 0.25 pieces of an article customer will get the error message "The totals of the cart item amounts do not match order amounts." when paying via PayPal Express Checkout.

If option Extension -> Modules -> Settings -> Show shopping cart on PayPal site is disabled everything works fine.
Steps To ReproducePaypal log attached
Additional InformationIf Extension -> Modules -> Settings -> Show shopping cart on PayPal site is enabled

in PayPal Request the parameter L_PAYMENTREQUEST_0_QTY1' => '0.25' -> Response 'ACK' => 'Failure'

If Extension -> Modules -> Settings -> Show shopping cart on PayPal site is disabled

in PayPal Request the parametet is set to L_PAYMENTREQUEST_0_QTY0' => '1' -> Response 'ACK' => 'Success'
TagsNo tags attached.

Relationships

has duplicate 0005770 resolvedsvetlana Paypal Error 

Activities

eike_spriess

2014-04-07 13:52

developer  

paypal_log.txt (5,076 bytes)
paypal_log.txt (5,076 bytes)

martinwegele

2014-04-07 17:43

reporter   ~0009817

Last edited: 2014-04-07 17:44

View 2 revisions

Maybe that's because PayPal only allows positive integers?
https://developer.paypal.com/webapps/developer/docs/classic/api/merchant/SetExpressCheckout_API_Operation_NVP/#id09BHCI005L7__N50362

martinwegele

2014-04-07 18:04

reporter   ~0009818

config parameter is evaluated here: https://github.com/OXID-eSales/paypal/blob/v3.0.2/source/modules/oe/oepaypal/models/paypalrequest/oepaypalsetexpresscheckoutrequestbuilder.php#L347

aurimas.gladutis

2014-09-16 15:22

reporter   ~0010161

If there are items with fraction quantities in basket, option for sending basket items will not be shown to the user despite config option and only grand total will be sent. Currently PayPal is not able to handle fraction quantities.