View Issue Details

IDProjectCategoryView StatusLast Update
0005492OXID eShop (all versions)5. ------ UpdateApp / Update ------public2014-02-19 15:02
Reporterray 
PriorityurgentSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version4.8.0 / 5.1.0 
Target Version4.7.12 / 5.0.12Fixed in Version4.8.5 / 5.1.5 
Summary0005492: Update App leads to error in step "Enter Theme"
Descriptionit was reported in forums, that the update app from 4.7.9 to 4.8.0 leads to an blocking error:

"Error accessing templates at: /home/kunden/webs/XXX/www.oxid.XXX.de/vhosts/application/views/azure/tpl using map: /home/kunden/webs/signbrem/www.oxid.XXX.de/vhosts/application/views/azure/en/map.php."
Steps To Reproduceinstall a fresh shop 4.7.9 with demodata and the update with the cumulative pack to 4.8.0

in second step it leads to the above error - not depending of your choice at "Enter Theme"
Additional Informationforum thread: http://forum.oxid-esales.com/showthread.php?t=20990

fix (reported working): http://forum.oxid-esales.com/showthread.php?t=20990#post134346

fix.sql as well attached to this report
TagsUpdate App
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005640 resolvedtadas Update 5.1/4.8 missing features 
has duplicate 0005511 closedjurate.baseviciene Update from 4.7.7 to 4.8.0 5.1.0 array_merge error 

Activities

leofonic

2013-11-04 10:13

reporter   ~0009209

The attached SQL is in fact a fix for a different error also mentioned in the forum thread: Collations are corrupted during update resulting in many errors in system health, "different collations for ID fields".

martinwegele

2013-11-04 10:40

reporter   ~0009211

Yes, leofonic is right. You should open a new report for that because it is a different issue.

jurate.baseviciene

2013-11-04 12:24

reporter   ~0009215

Steps to reproduce
1. Please push "Start" button to begin updating.
Click on the button „Start update“
2. Do you want update language constants and mapping for your themes?
3. Select „Yes“ and then click on the button „ Continue“

4. Again run -> /updateApp/

5. Please push "Start" button to begin updating.
Click on the button „Start update“

martinwegele

2013-11-04 16:05

reporter   ~0009219

I reported the second issue separately: 0005497

Mitmacher

2013-11-06 18:35

reporter   ~0009239

Thx and sorry for this confusion! ;-)
Btw: my SQL fix also works with UTF-8 as leofonic mentioned. I've added some more info within the forum thread...

tadas

2014-02-19 15:02

reporter   ~0009530

It should be more clear why errors occur with maps and templates, and it should not throw unexpected warnings and notices.