View Issue Details

IDProjectCategoryView StatusLast Update
0005640OXID eShop (all versions)5. ------ UpdateApp / Update ------public2014-02-10 16:59
Reportertadas 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.1 / 5.1.1 
Target Version4.8.4 / 5.1.4Fixed in Version 
Summary0005640: Update 5.1/4.8 missing features
DescriptionWith the introduction of map replacement in recent updateApp (5.1/4.8), maps can be replaced for certain themes. Few missing features/problems were found:
 a) Update app doesn't work well with theme inheritance. For example, if a certain templates(residing in 'custom') are extended for a theme('azure'), and you want to replace map in 'custom' theme, and the map.php does not exist in 'custom' theme folder, you will get an error, and no change will be made with it.
 b) Ambiguous error when updateApp fails due to previously mentioned reason. You will get error: "Error accessing templates at: /a/b/c/tpl using map: /a/b/c/en/map.php", although it could happen for different reasons:
     - Map is empty/not found.
     - Templates are not found/not accessible at the location provided
It throws an error in updateApp, and loops back to the start afterwards to try again.
TagsUpdate App
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005492 resolvedtadas Update App leads to error in step "Enter Theme" 
related to 0005646 resolvedtadas When map is missing error is displayed, when templates are not found info text is updated 

Activities

tadas

2014-02-10 16:58

reporter   ~0009487

Update will now notify user when templates are not found or map is empty/doesn't exist