View Issue Details

IDProjectCategoryView StatusLast Update
0006011OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2016-09-14 10:54
Reporterd3 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.9.2 / 5.2.2 
Target VersionFixed in Version6.0.0-beta.1 
Summary0006011: Function 'getFileUrl' does not exist or is not accessible!
DescriptionThe file "EXCEPTION_LOG.txt" recorded the following message, each time the details page is loaded: Function 'getFileUrl' does not exist or is not accessible!

This method (in class: oxarticle) was deprecated in version 4.8.x and was removed in version 4.9.x.

In the template file: application\views\azure\tpl\page\details\inc\media.tpl
this method is still used ($oDetailsProduct->getFileUrl()).
TagsSolution Provided
ThemeAzure
BrowserAll
PHP VersionNot defined
MySQL VersionNot defined

Relationships

has duplicate 0006331 closed with an defined File (products -> extended) product details can not be displayed (frontend) 

Activities

martinwegele

2015-07-08 16:26

reporter   ~0011088

Last edited: 2015-07-08 16:26

View 3 revisions

http://wiki.oxidforge.org/Tutorials/Removed_deprecated_source#Removed says: "oxArticle::getFileUrl() - Article file is duplicate of media. Use oxArticle::getMediaUrls() instead for file media."

vanilla thunder

2015-08-16 23:14

reporter   ~0011166

just in case someone want a quick fix for your shop:
https://github.com/vanilla-thunder/fix-fileurl

netfeld

2016-04-01 11:55

reporter   ~0011507

Bug still alive in 4.9.7 (azure) This is not a peace of cake: details page is not loading!

Sorry martinwegele: you are wrong. There are 2 different types of media files: first the list of media files. here you can use getMediaFiles() (or getMediaUrls()) as it is done in azure. Second is the property of oxartice "oxfile". And the missing function getFileUrl() does nothing else then get the actual upload path. So vanilla is absolutly right with his fix. And oxid should fix this.

Dariush Ghiass-Fakhri

2016-09-14 10:53

reporter   ~0011783

As netfeld said, there are two different types of media files.
The old type "oxfile" will should not be used anymore.
Please use the new type "MediaURLs".

https://github.com/OXID-eSales/oxideshop_ce/commit/984c6e89d4207469f8b6ec046e74fd8a7e779f69