View Issue Details

IDProjectCategoryView StatusLast Update
0005630OXID eShop (all versions)2.4. Administer productspublic2014-09-03 10:05
Reportermartinwegele 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.1 / 5.1.1 
Target Version4.8.8 / 5.1.8Fixed in Version4.9.0_5.2.0_RC1 
Summary0005630: Setting a category as the main category collides with subshop
DescriptionIn an OXID eShop Enterprise Edition with two subshops where one inherits all articles from the other it is impossible to set different main categories for the same article in each subshop.
Additional InformationThere seems to be a problem with the layout of the table oxobject2category and the use of oxtime. This is not "multi-shop safe".
TagsCategory, Documentation, EE, Subshops
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005724 acknowledged Wrong main category url showing in backend. Differs from frontend. 

Activities

martinwegele

2014-01-30 10:45

reporter   ~0009456

This seems to be no problem in the frontend because the main category is determined like this for example:
$sQ = "select oxcatnid from ".getViewName( "oxobject2category" )." where oxobjectid = ".$oDb->quote( $sArtId )." order by oxtime";
/* removed some lines in between */
            $sMainCatId = $oDb->getOne( $sQ );

see: https://github.com/OXID-eSales/oxideshop_ce/blob/v4.8.2/source/application/models/oxseoencoderarticle.php#L328
or https://github.com/OXID-eSales/oxideshop_ce/blob/v4.8.2/source/application/models/oxarticle.php#L1524
However in the popup for category assignment the marking does not check for the lowest value but only for 0:
https://github.com/OXID-eSales/oxideshop_ce/blob/v4.8.2/source/application/views/admin/tpl/popups/article_extend.tpl#L29 (?)
Therefore it is probably just a problem of displaying ("highlighting") the main category in this popup in the admin area.

tadas

2014-08-25 10:33

reporter   ~0010089

Main category handling will take different shops into account and will work with currently selected shop instead of working with all shops at once.