View Issue Details

IDProjectCategoryView StatusLast Update
0005599OXID eShop (all versions)2.4. Administer productspublic2014-02-10 09:52
Reporter[email protected] 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.3 / 5.0.3 revision 54408 
Target VersionFixed in Version4.8.4 / 5.1.4 
Summary0005599: Administration products with variants - field OXNONMATERIAL is reset when updating OXBPRICE
DescriptionWhile updating field OXBPRICE adv. OXTPRICE of a product variant in the SHOP Admin the field OXNONMATERIAL is reset from '1' to '0'.
Steps To Reproduce1. Open Shop Admin
2. Select a nonmaterial product with variants
3. Select a product variant
4. Change field Purchase Price (€) or field RRP
5. Check value OXNONMATERIAL for the product variant which was edited.
Additional InformationRelated Ticket https://bugs.oxid-esales.com/view.php?id=3133
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0003133 assignedflorian.auer allow changes for oxfreeshipping, oxnonmaterial in variants 
related to 0002963 resolvedvilma_liorensaityte Display oxfreeshipping, oxnonmaterial and oxremindactive as read-only for variant-products 

Activities

martinwegele

2014-01-10 16:55

reporter   ~0009405

correction: It happens when you submit the form of article_extend for a variant of that article. The checkbox for oxnonmaterial will always be checked because of the setting of the parent: https://github.com/OXID-eSales/oxideshop/blob/b-dev/source/application/controllers/admin/article_extend.php#L73
But you cannot edit that value for the variant: https://github.com/OXID-eSales/oxideshop/blob/b-dev/source/application/views/admin/tpl/article_extend.tpl#L241
I reproduced it on an EE 5.0.4 but I guess that it can be reproduced on any version since the introduction of that feature (4.5.1?).

Linas Kukulskis

2014-01-13 11:58

reporter   ~0009409

Last edited: 2014-01-13 23:10

View 2 revisions

everything is ok; in db layer in variants OXNONMATERIAL field can be 0, on object load it will be changed according parent value.

Linas Kukulskis

2014-01-15 12:06

reporter   ~0009422

bug reopened. decision: db layer also should include the same information that we have in loaded oxArticle object;

Linas Kukulskis

2014-02-10 09:51

reporter   ~0009483

added update on save of these fields