View Issue Details

IDProjectCategoryView StatusLast Update
0003133OXID eShop (all versions)2.4. Administer productspublic2015-12-01 09:28
Reporterray 
PriorityhighSeverityfeatureReproducibilityalways
Status assignedResolutionreopened 
Product Version4.5.1 revision 38045 
Target VersionFixed in Version 
Summary0003133: allow changes for oxfreeshipping, oxnonmaterial in variants
Descriptionrelated to https://bugs.oxid-esales.com/view.php?id=2963

To inherit the options oxfreeshipping and oxnonmaterial is basically correct as default values, but you should have the possibility to change them if needed.
Just think about Books / eBooks, CDs / MP3s, Software on CD / as download or even paintings / pictures. There are quite a few scenarios in which you have material and nonmaterial variants of the same main article.
TagsDownloadable Products, Products, Variants
ThemeNot defined
BrowserAll
PHP VersionNot defined
MySQL VersionNot defined

Relationships

related to 0002963 resolvedvilma_liorensaityte Display oxfreeshipping, oxnonmaterial and oxremindactive as read-only for variant-products 
related to 0005599 resolvedLinas Kukulskis Administration products with variants - field OXNONMATERIAL is reset when updating OXBPRICE 

Activities

dainius.bigelis

2011-11-16 10:25

reporter   ~0005386

Entry closed as Duplicate of 0002963. The feature request to handle these options is inserted in UserVoice: http://oxid.uservoice.com/forums/31940-feature-requests/suggestions/2301824-option-to-change-oxnonmaterial-oxfreeshipping-fo

ray

2012-12-10 08:06

reporter   ~0008078

Last edited: 2012-12-10 08:15

View 3 revisions

actually this option should be implemented soon, as the current situation foils a big part of the great enhancement "downloadable products"

http://forum.oxid-esales.com/showthread.php?t=10865

In this example of configuring downloadable variants for articles you will have same settings for shipping as the father article:
http://wiki.oxidforge.org/Features/Downloadable_products#Downloadable_products_and_variants
(which does not make sense at all - invoicing shipping costs for a download...)

Liquinaut

2013-12-08 20:38

reporter   ~0009345

This feature has been requested 2 years ago and still is essential for download handling. Please implement soon!

svetlana

2014-03-28 10:05

reporter   ~0009751

waiting for the PO decision.