View Issue Details

IDProjectCategoryView StatusLast Update
0002963OXID eShop (all versions)1.03. Basket, checkout processpublic2012-12-10 14:13
ReporterChristophH 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.0 revision 34568 
Target VersionFixed in Version4.5.1 revision 38045 
Summary0002963: Display oxfreeshipping, oxnonmaterial and oxremindactive as read-only for variant-products
DescriptionThe options oxfreeshipping, oxnonmaterial and oxremindactive are always inherited to Variants from Parent products. So:
1. when Variant product is selected, these options should be displayed as read-only. The Value, set in the Parent product should be displayed (the option checked or no).
2. Help text, explaining this concept should be displayed next to these options.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005599 resolvedLinas Kukulskis Administration products with variants - field OXNONMATERIAL is reset when updating OXBPRICE 
related to 0003133 assignedflorian.auer allow changes for oxfreeshipping, oxnonmaterial in variants 

Activities

dainius.bigelis

2011-06-09 11:18

reporter   ~0004724

Reminder sent to: ChristophH

Hi,

The behavior is not a bug, because few of the options are always inherited to from Parent-product to Variant-product:
- oxnonmaterial
- oxfreeshipping
- oxremindactive
That's because these options are general for all the product and should not be different for particular variants (i.e. Parent product is material and just one of variants is non-material).
But the bug is that these options are shown as active for variant-products. So we decided to show these for variants as -read-only, with proper explanation.
The description of entry will be changed according this idea.