View Issue Details

IDProjectCategoryView StatusLast Update
0005544OXID eShop (all versions)1.03. Basket, checkout processpublic2014-06-18 10:46
Reporterenki 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformlinux/nginx + apacheOSOS Version
Product Version4.8.0 / 5.1.0 
Target Version4.9.0_5.2.0_beta1Fixed in Version4.8.5 / 5.1.5 
Summary0005544: --> state gets written in numbers not letters <--
Descriptionbasket/checkout/pdf adressfield show the mysql oxid stateID instead of oxid state title
Steps To Reproduceplace order for internaional shipping
use countries with states !
->goto next step
--> state gets written in the generated adressfield in numbers not letters <--

TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Version5.4
MySQL Versionany

Relationships

related to 0005595 acknowledged User's state is saved in wrong way 
child of 0005029 resolvedgregor.hyneck PrimaryKey in "oxstates" table only set on column "OXID" 

Activities

svetlana

2013-12-02 15:29

reporter  

2013-12-02_1629.png (7,661 bytes)
2013-12-02_1629.png (7,661 bytes)

aurimas.gladutis

2014-04-15 09:03

reporter   ~0009836

Reverted state ids back to isoalpha values, as to change all places where id is used as code requires template changes and will only go to future version.

enki

2014-05-07 00:16

reporter   ~0009891

Bug not fixed! problem still there after update to newest version 4.8.5

svetlana

2014-05-13 13:54

reporter   ~0009905

The problem is resolved since 5.1.5/4.8.5 version, but not in the update to 5.1.5/4.8.5.

Linas Kukulskis

2014-06-18 10:46

reporter   ~0009975

use this sql script to fix data if some users or address where created with state oxid not isoalpha:
UPDATE `oxaddress`
  INNER JOIN `oxstates` ON `oxstates`.`oxid` = `oxaddress`.`oxstateid`
SET `oxaddress`.`oxstateid` = `oxstates`.`oxisoalpha2`;

UPDATE `oxuser`
  INNER JOIN `oxstates` ON `oxstates`.`oxid` = `oxuser`.`oxstateid`
SET `oxuser`.`oxstateid` = `oxstates`.`oxisoalpha2`;

UPDATE `oxstates` SET `oxid` = `oxisoalpha2`;

Linas Kukulskis

2014-06-18 10:46

reporter   ~0009976

resolved