View Issue Details

IDProjectCategoryView StatusLast Update
0005029OXID eShop (all versions)2.7. Customer infopublic2017-07-06 09:17
ReporterStefan Krenz 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.0 / 5.0.0 revision 51243 
Target VersionFixed in Version6.0.0-rc.2 
Summary0005029: PrimaryKey in "oxstates" table only set on column "OXID"
DescriptionThe primary key in the table "oxstates" is only set on the column "OXID", which includes only the abbreviation of the state.
If you have two states with the same abbreviation, but different countries, they can not be stored in the database.
Additional InformationThe PK should be set on the column "OXCOUNTRYID" and "OXID" (in this order), to get really be unique.
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP VersionNot defined
MySQL VersionAll

Relationships

parent of 0005544 resolvedLinas Kukulskis --> state gets written in numbers not letters <-- 

Activities

mantas.vaitkunas

2013-04-03 16:37

administrator   ~0008556

"OXID" can be any unique char, visually you will not see these values. So you can change it as you want(must be unique).
In next version we added change that "OXID" values would be simple integers.

svetlana

2014-04-15 13:04

reporter   ~0009838

This bug fix was reverted because of 0005544

gregor.hyneck

2017-07-06 09:17

administrator   ~0012178

Fixed with this commit: https://github.com/OXID-eSales/oxideshop_ce/commit/79c2568c53af4213946e70cd6f50c5d0e86f1289