View Issue Details

IDProjectCategoryView StatusLast Update
0005471OXID eShop (all versions)4.09. SEO, SEO URLpublic2015-07-07 13:14
Reportermarco_steinhaeuser 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.8 / 5.0.8 
Target Version4.9.5 / 5.2.5Fixed in Version4.9.5 / 5.2.5 
Summary0005471: Redirect 302 shall be 301 if title changes
DescriptionChanging the title of a product or category item will change the URL as well. The old URL is still accessible and shall redirect permanently (301) to the new page. Instead, http header 302 (redirect temporarily) is delivered.
Additional InformationIn this document the SEO concept is described and leads clearly to 301:
http://wiki.oxidforge.org/Tutorials/Understanding_OXID_SEO#Handling_Legacy_URLs

Whenever this was changed, it was not documented.
TagsNo tags attached.
ThemeAll
BrowserAll
PHP VersionNot defined
MySQL VersionNot defined

Activities

martinwegele

2013-10-15 15:29

reporter   ~0009155

Last edited: 2013-10-16 09:57

View 2 revisions

The default value of the third parameter of oxUtils::redirect() was changed to 302 in revision 56432/56326 as a fix for 0004319. I guess that this change affects the functionality of oxSeoDecoder::processSeoCall() because there the third parameter is not set explicitly but instead it relies on the default value of oxUtils::redirect().
So the problem is probably present since version 5.0.4.

JaroslavHerber

2015-03-16 14:54

reporter   ~0010802

Last edited: 2015-03-16 15:04

View 2 revisions

I agree.

In oxUbase::_processRequest() on line 582:
- the 3rd param of the redirect-method should be 301!

-> Because search-engines don't like md5-valued GET-params. So we must tell them a permanenty moved 301 to a SEO-friendly URL. And not a temporary 302!!!

Please fix.

Adrian.Kirchner

2015-04-23 23:26

reporter   ~0010904

This bug is addressed in PR 234: https://github.com/OXID-eSales/oxideshop_ce/pull/234

I stumpled upon this bug in a current project and imho, depending on the use case, this bug is rather serious.