View Issue Details

IDProjectCategoryView StatusLast Update
0004319OXID eShop (all versions)4.07. Source code, Testpublic2013-03-21 12:10
Reporterd3 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version4.6.7Fixed in Version4.7.4 / 5.0.4 revision 57063 
Summary0004319: permanently redirect 301 to offline.html should be 307
Descriptionin oxcmp_shop::render::59
oxUtils::getInstance()->redirect($sShopUrl . 'offline.html', false);
redirects with an 301

should be
oxUtils::getInstance()->redirect($sShopUrl . 'offline.html', false, 307);
TagsOffline, Redirect
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005009 resolvedLinas Kukulskis Redirect in case of an error must be 307 and not 301/302 
related to 0003244 resolvedarvydas_vapsva Newer Browser are caching 301 Redirects 

Activities

d3

2012-08-07 10:18

reporter   ~0007241

I meant 307 in title

mr_dimson

2013-02-22 10:45

reporter   ~0008439

Is someone working on this bug yet?

301 redirects cause the "offline.html" page is shown to the users although the shop is online. Only after clearing the browser caches the site is available again.

martinwegele

2013-02-28 10:25

reporter   ~0008460

Last edited: 2013-02-28 11:36

View 2 revisions

We should increase the priority of this bug because if the shop visitor will be redirected to offline.html (301 = Moved permanently!) and if the browser caches that, this redirect will be permanent so the shop visitor does not have an easy opportunity to get back to the shop (which is actually not offline).
Maybe it would be better in this case to send an error code 503 Service Unavailable?

Linas Kukulskis

2013-03-07 13:37

reporter   ~0008488

changed default value to 302