View Issue Details

IDProjectCategoryView StatusLast Update
0005009OXID eShop (all versions)4.09. SEO, SEO URLpublic2013-04-08 14:34
ReporterBergfreunde 
PriorityhighSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.3 / 5.0.3 revision 54408 
Target VersionFixed in Version4.7.5 / 5.0.5 
Summary0005009: Redirect in case of an error must be 307 and not 301/302
DescriptionRedirect in case of an error must be 307 and not 301/302

307 in case of error
In 4.5.3 this fix was added https://bugs.oxid-esales.com/view.php?id=3244
It seems that it got lost.

Reason: Modern Browser cache a 301 according to rfc.
http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html#sec10.3.2 [^]

Note: A SEO-Redirect (old url to new one) must be a 301.

307 and not 302
And the redirect changed because of https://bugs.oxid-esales.com/view.php?id=4319 should be an 307 like d3 said and not a 302.

Reason: SearchEngines don't like 302 because of url-hijacking (see http://de.wikipedia.org/wiki/HTTP-Statuscode)
Tags301, 302, 307, Redirect
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0003244 resolvedarvydas_vapsva Newer Browser are caching 301 Redirects 
related to 0004319 resolvedLinas Kukulskis permanently redirect 301 to offline.html should be 307 

Activities

Linas Kukulskis

2013-04-08 14:34

reporter   ~0008571

changed to 307