View Issue Details

IDProjectCategoryView StatusLast Update
0005270OXID eShop (all versions)2.3. Extensions (modules, themes)public2014-01-08 11:42
ReporterLinas Kukulskis 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version4.7.6 / 5.0.6 
Target Version4.7.11 / 5.0.11Fixed in Version 
Summary0005270: after deactivation still data in db
Descriptionif you have activate the same module on 2 subshops, after deactivation in both the oxconfig and oxconfig display tables must be empty of the module configs, but oxconfigdisplay still has records. also after activation for one config parameter for earch subshops in oxconfigDisplay table must be 2 records now is 1. seems one subshoip overwrites other subshop oxconfigDisplay values
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0004129 resolvedLinas Kukulskis metadata.php changes are not committed right to aModules 
related to 0004025 resolvedLinas Kukulskis no update of tbl:oxtplblocks by changing module/metadata.php 'blocks' => array() 
related to 0004942 acknowledged Changing Module ID will move old module(id) to aDiabledModules and let them stay there until the module directory is deleted 
related to 0004866 resolvedLinas Kukulskis Start page header element (including CSS) disappear after ruining installed PayPal module. 

Activities

mantas.vaitkunas

2014-01-08 11:41

manager   ~0009389

On module deactivation there is no need to delete entries. Also there is no need to create additional entries in oxconfigdisplay table, because it would be duplicated in every subshop.