View Issue Details

IDProjectCategoryView StatusLast Update
0005164OXID eShop (all versions)1.06. Search, Tagspublic2013-06-19 09:00
Reporterd3 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version4.7.3 / 5.0.3 revision 54408 
Target VersionFixed in Version 
Summary0005164: View class "search" haven't got an own sort ident.
DescriptionAll article lists (including search result list) have the same sort ident "alist" (defined in oxubase). So search article lists can't have a different sorting to category article lists.
Additional InformationPlease add

public function getSortIdent()
{
    return 'oxsearch';
}

in search.php.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0002992 resolvedLinas Kukulskis Selected sorting, items per page and type of the list is not saved when navigating to other category 

Activities

jurate.baseviciene

2013-06-19 08:58

reporter   ~0008789

Reminder sent to: d3

 Hi,

 In this case it's not a bug. We implemented that sorting will be applied for all product list, category, search, vendor, manufacturer, tag. For more detail you can see "https://bugs.oxid-esales.com/view.php?id=2992". So search article lists can't have a different sorting to category article lists ant that is correct.

Best regards