View Issue Details

IDProjectCategoryView StatusLast Update
0002992OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2013-01-09 16:52
ReporterHolger Kohnen 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.0 revision 34568 
Target Version4.7.3 / 5.0.3 revision 54408Fixed in Version4.7.3 / 5.0.3 revision 54408 
Summary0002992: Selected sorting, items per page and type of the list is not saved when navigating to other category
DescriptionIf the customer selects sorting for category A and than goes to category B sorting hast to be selected again.

Code in alist, oxubase causing this problem.

A possible fix, would use a fixed $cnid parameter for setItemSorting, getSorting and getSortingSql in alist, like in search-view.

I think the real intention of this code is to store different sorting settings in session for different object-types and this would make sense, since different objects can have different properties to sort against. But storing different sorting settings for different objects with the same type makes no sense, or is at least counter-intuitive for the customer.

Decision is to save the sorting of the list for user, that it would be applied to other category lists, when navigating through the shop.

Also for user convenience shop should save two other options - "type of the list" (Grid/Double grid/Line) and the "items per page".
Steps To Reproduce1.) Select a category in shop frontend
2.) Setup sorting
3.) Select other category
=> Sorting is lost
TagsCategory, Sorting
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0003906 resolvedtomas_liubinas Sorting criteria is not passed to cache key, therefore sorting in cached version does not work 
related to 0004903 resolvedLinas Kukulskis default sorting in category 
related to 0005164 closedjurate.baseviciene View class "search" haven't got an own sort ident. 

Activities

dainius.bigelis

2012-03-16 10:44

reporter   ~0006016

We are discussing in team, maybe implement an option for that, which would mark if sorting should be saved for other categories or no.
Also when option would be ON - it would save not only the sorting, but List type (grid/double grid/line) and items per page.
Decision will follow.

dainius.bigelis

2012-03-29 15:43

reporter   ~0006112

Decision is taken to save the sorting, together with "items per page" and type of the list. I changed bug description according that.

dainius.bigelis

2012-04-25 12:17

reporter   ~0006443

Issue reopened, because fix was not correct and leads to other issues in sorting

Linas Kukulskis

2013-01-09 16:52

reporter   ~0008242

fixed, sorting will be applied for all product list: category, search, vendor, manufacturer, tag.