View Issue Details

IDProjectCategoryView StatusLast Update
0005084OXID eShop (all versions)1.03. Basket, checkout processpublic2015-10-05 12:15
Reportermatthias 
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.2 revision 46646 
Target Version4.6.7Fixed in Version4.6.7 
Summary0005084: Error 0005055 is not resolved
DescriptionThe hint for adding rel="nofollow" is not a solution for the described problem. You could use oxbasket::getPaymentCosts() in every template or php-script you want, not only in checkout. If you use this function there will be an exception because getPaymentCosts does not check the return value of oxbasket::getCosts but instead calls the next function directly. The result is the script will abort, if a crawler visit the shop.
TagsBasket, Calculations, Price Calculation
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

child of 0005055 resolvedtadas oxbasket::getPaymentCosts() does not test for null return 

Activities

Linas Kukulskis

2013-04-29 14:01

reporter   ~0008641

added check for null statement