View Issue Details

IDProjectCategoryView StatusLast Update
0005055OXID eShop (all versions)1.03. Basket, checkout processpublic2015-10-05 12:15
Reportermartinwegele 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Product Version4.6.2 revision 46646 
Target Version4.6.7Fixed in Version 
Summary0005055: oxbasket::getPaymentCosts() does not test for null return
DescriptionA shop owner reported bad (or even no) listings in the results for his articles in the Google search. His SEO consultant told him that the Google crawler/bot "gets stuck" somewhere on their page and quits indexing (I could not verify this of course).
Their partner says that the error was this:
oxbasket::getPaymentCosts() calls oxbasket::getCosts which returns NULL if calculateBasket() was not performed in advance. Because of oxbasket::isEnabled() calculateBasket() is not performed if the shop is visited by a crawler.
Since getPaymentCosts does not check the return value of oxbasket::getCosts but instead calls the next function directly the script will abort.
Steps To Reproduceunknown.
Additional InformationCompare oxbasket::getFPaymentCosts().
I know that the method was changed in 4.7.0.
Question: Is the missing check for null return values really a problem for crawlers?
TagsBasket, Calculations, Price Calculation
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

parent of 0005084 resolvedLinas Kukulskis Error 0005055 is not resolved 

Activities

tadas

2013-04-11 11:35

reporter   ~0008594

Last edited: 2013-04-11 11:35

View 2 revisions

Try adding rel="nofollow" to cart links if they don't have this attribute in them. See if this helps.