View Issue Details

IDProjectCategoryView StatusLast Update
0004911OXID eShop (all versions)1.03. Basket, checkout processpublic2013-02-14 12:33
Reporterian 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.2 / 5.0.2 revision 53018 
Target Version4.7.4 / 5.0.4 revision 57063Fixed in Version4.7.4 / 5.0.4 revision 57063 
Summary0004911: Impossible to delete articles with "Selection List" from Wishlist
DescriptionThis bug was already reported for version 4.1.1 revision 18442 and marked as fixed (ticket: 0000870 - https://bugs.oxid-esales.com/view.php?id=870) but it appears again in version 4.7.2.

The fix mentioned in the ticket 0000870 solves it.
TagsSelection List
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0000870 resolvedarvydas_vapsva Impossible to delete articles with "Selection List" from Wishlist 
related to 0004927 acknowledged Can't properly add/display items to wishlist with multiple selection lists 

Activities

tadas

2013-02-08 15:18

reporter   ~0008395

Reminder sent to: ian

We are unable to reproduce this bug. If you can reproduce it on our demo shop at http://demoshop.oxid-esales.com/community-edition/ , please write it in more details.

ian

2013-02-08 16:18

reporter   ~0008396

Of course it's no surprise that the demo shop works fine.

jurate.baseviciene

2013-02-11 07:36

reporter   ~0008397

Reminder sent to: ian

Hi,

Thanks a lot for submitting this issue, but unfortunately we can not reproduce this issue any more. So please explain more detailed how need to reproduced this issue? maybe some other special options are turned on?
Also I tried to reproduce this issue on 4.7.2 version but unsuccessfully.

Best regards

ian

2013-02-12 09:16

reporter   ~0008400

Last edited: 2013-02-12 09:16

View 2 revisions

The explanation on how to produce it is outlined in 0000870, it's exactly the same, there's nothing more I can add.

All I know is that we have version 4.7.2 installed and that it was impossible to remove articles with "selection lists" from the wish and notice lists. The fix suggested by one of your managers (in that thread): "Problem in object id selection (oxcmp_utils::toNoticeList()) - first should be checked 'itmid' parameter, and, if its[sic] not set, 'aid' should be used" - fixed it.

It is possible, I suppose, that somehow an old copy of the oxcmp_utils.php file remained in the install, but as a new developer to OXID I really don't know.