View Issue Details

IDProjectCategoryView StatusLast Update
0004622OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2014-03-07 10:19
Reportersvetlana 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.11 revision 46050 
Target Version4.8.5 / 5.1.5Fixed in Version4.8.5 / 5.1.5 
Summary0004622: Intangible product should not be calculated in shipping price.
DescriptionWhen option "Don't consider intangible Products (e.g. Gift Certificates) in Shipping Costs Calculation" is on intangible product should not be calculated in shipping price.
Steps To Reproduce1. In admin/master settings/core settings/settings/other settings set this option ON: "Don't consider intangible Products (e.g. Gift Certificates) in Shipping Costs Calculation"
1. Create 2 product. one of them should have an option: "Intangible Product"
2. Create shipping method with price 10 % of total price.

Add to basket these two products and see that shipping price is 10% of total price of two products, should be 10% of one product total, because one of them is marked as intangible.
If in basket added just one intangible product then shipping price is 0 and it works correct.
TagsBasket, Delivery, Products
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

has duplicate 0004849 resolvedLinas Kukulskis Wrong shipping costs for intangible products / free shipping products 

Activities

Linas Kukulskis

2014-03-07 10:19

reporter   ~0009616

fixed. if option on then will not include