View Issue Details

IDProjectCategoryView StatusLast Update
0004494OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2012-12-07 14:25
Reporterskshopdev 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.6.4 revision 49061 
Target VersionFixed in Version 
Summary0004494: Possible to select multidimensional variants which are not configured
DescriptionIn Azure it is possible to select multidimensional variants which are not configured in backend. The options aren't properly shown as disabled.

See steps to reproduce.

All variant options can be selected but the article can't be put in the basket. That's correct, but obviously selecting an option which is not possible should reset the variant selection.
I didn't dig deeper in this, but it should be the value for $selection->isDisabled() which should be set in _applyVariantSelectionsFilter
Steps To ReproduceCreate 3 Variants:
Name: A | B | C
Values:
1 | 1 | 1
1 | 2 | 2
2 | 1 | 2

Activate them.

In Frontend choose for the first two boxes 1.
The third box shows 1 and 2 both active, but there is no variant 1|1|2. So the second option should be gray (shown as disabled).
This works if you select 1|2: third box shows 1 in gray because there is no 1|2|1 but there is 1|2|2.
Additional InformationHope it's in the right category.
TagsSelection List
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0004206 resolvedaurimas.gladutis Sometimes it is possible to select unavailabe variant 

Activities

skshopdev

2012-09-07 11:54

reporter  

leofonic

2012-09-13 20:56

reporter   ~0007454

Duplicate of 0004206

jurate.baseviciene

2012-11-09 13:43

reporter   ~0007803

Closed as duplicate of 0004206