View Issue Details

IDProjectCategoryView StatusLast Update
0004486OXID eShop (all versions)4. ------ eShop Core -------public2012-12-10 13:42
ReporterFibreFoX 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.4 revision 49061 
Target VersionFixed in Version4.8.0_5.1.0_beta1 
Summary0004486: oxcategories should have DEFAULT on oxpricefrom/oxpriceto
DescriptionAfter playing with the categories, i stumbled upon some missing default-entries in setup/database.sql


CREATE TABLE `oxcategories` (
...
  `OXPRICEFROM` double default NULL,
  `OXPRICETO` double default NULL,
...
);

When having some entries with NULL in it, assigning articles to categories via admin-interface is impossible, because the resulting statement is something like this:

select oxv_oxcategories_de.oxtitle as _0, oxv_oxcategories_de.oxdesc as _1, oxv_oxcategories_de.oxid as _3 from oxv_oxcategories_de where oxv_oxcategories_de.oxid not in ( select oxv_oxcategories_de.oxid from oxobject2category left join oxv_oxcategories_de on oxv_oxcategories_de.oxid=oxobject2category.oxcatnid where oxobject2category.oxobjectid = '7060b0d553364f113108074978543ed1' and oxv_oxcategories_de.oxid is not null ) and oxv_oxcategories_de.oxpriceto = '0'


"oxv_oxcategories_de.oxpriceto = 0" is totally wrong here and results in empty categorylists
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

has duplicate 0005302 resolvedLinas Kukulskis Table oxcategories -> default value if OXPRICEFROM and OXPRICETO should be 0 
related to 0004967 resolvedLinas Kukulskis Problem while assigning products to categories 

Activities

FibreFoX

2012-09-03 14:54

reporter  

empty_categorylist.PNG (104,229 bytes)
empty_categorylist.PNG (104,229 bytes)

Linas Kukulskis

2012-11-21 16:42

reporter   ~0007936

Last edited: 2013-03-06 15:24

View 2 revisions

changed, default oxpriceto and oxpricefrom field values from null to 0