View Issue Details

IDProjectCategoryView StatusLast Update
0004967OXID eShop (all versions)2.4. Administer productspublic2013-03-08 10:25
Reportermr_dimson 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.6 revision 54646 
Target Version4.7.4 / 5.0.4 revision 57063Fixed in Version4.7.4 / 5.0.4 revision 57063 
Summary0004967: Problem while assigning products to categories
DescriptionThere's a problem with assigning products to categories - only categories with OXPRICETO=0 are shown in the select list.

In application/controllers/admin/article_extend_ajax.php, line 72:

$sQAdd .= " where $sO2CView.oxobjectid = " . $oDb->quote( $sSynchOxid ) . " and $sCategoriesTable.oxid is not null ) and $sCategoriesTable.oxpriceto = '0'";
TagsCategory, Products
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0004486 resolvedLinas Kukulskis oxcategories should have DEFAULT on oxpricefrom/oxpriceto 

Activities

mr_dimson

2013-02-27 11:06

reporter  

snapshot14.png (58,285 bytes)
snapshot14.png (58,285 bytes)

leofonic

2013-02-28 14:18

reporter   ~0008462

maybe duplicate of 0004486

Linas Kukulskis

2013-03-06 15:26

reporter   ~0008480

added additional check on category save: if oxpriceto and oxpricefrom is empty set to 0.

.... and $sCategoriesTable.oxpriceto = '0'"; - is used to escape of price categories they should not have any article.

please check your db if there are null values on this field update to 0. this part is related with 0004486 fix.