View Issue Details

IDProjectCategoryView StatusLast Update
0004200OXID eShop (all versions)4.03. 3rd party librariespublic2016-04-27 08:30
ReporterFibreFoX 
PrioritylowSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.1 revision 45706 
Target VersionFixed in Version4.9.8 / 5.2.8 
Summary0004200: Update phpmailer to latest revision
DescriptionThe used version of PHPMailer is now outdated for over 2 years. Some "performance improvements" would be great if they are here too.
Tags3rd Party Libraries, Email
ThemeAzure
BrowserAll
PHP VersionNot defined
MySQL VersionNot defined

Relationships

has duplicate 0005835 closed SMTP-Configuration - PHPMailer not RFC conform 
related to 0005896 resolvedsaulius.stasiukaitis Deprecated: Function set_magic_quotes_runtime() is deprecated in ......./class.phpmailer.php on line 1350 
related to 0006314 acknowledgedflorian.auer Non endoded "Umlauts" in Email not working 

Activities

FibreFoX

2012-06-26 17:48

reporter   ~0006990

Last edited: 2012-06-26 17:48

View 2 revisions

The class-fields are now "protected" (not private anymore), i think some methods can be removed or at least being refactored.

FibreFoX

2013-04-04 14:44

reporter   ~0008562

note: current version supports a lot more than the current oxid one.

https://github.com/Synchro/PHPMailer/blob/master/changelog.md

some features/improvements:
* DKIM digital signing
* Performance improvements
* a lot of bugs closed
* Return-Path can now be user defined
* AUTH PLAIN SMTP authentication
* CRAM-MD5 authentication

svetlana

2014-03-28 10:01

reporter   ~0009723

waiting for the PO decision.

FibreFoX

2014-07-30 10:57

reporter   ~0010049

Last edited: 2014-07-30 11:09

View 2 revisions

This bug is really old, do you have an ETA for the PO decision (or just some information about the priority of this bug)?

Targeted product was 4.8.5, we are at 4.8.7 right now, would be nice to find this in some of the next releases very soon.

EDIT: due to the fact this bug-ticket already having a duplicate should rise the importance from "feature" to real "bug"

cesnauskast

2014-08-07 13:27

administrator   ~0010062

We are looking through all 3rd party libraries and evaluating them.
All changes will be presented with the Next Major Version.

FibreFoX

2014-10-13 15:25

reporter   ~0010230

"Target Version" was "4.9.0_5.2.0_RC1" but seems not to be changed in 4.9.0? Some ETA for this?

jurate.baseviciene

2014-11-10 08:16

reporter   ~0010321

Hi,

Sorry that we confused you with target version (4.9.0_5.2.0_RC). But as @cesnauskast mentioned above that we evaluating 3rd party libraries and all changes will be presented with the Next Major Version.

Best regards,
Jurate

FibreFoX

2016-02-01 20:06

reporter   ~0011448

Any progress on this? This isn't a feature anymore ... it becomes a real bug with the other linked bugs... there isn't a target-version anymore ...

saulius.stasiukaitis

2016-03-15 10:51

reporter   ~0011496

PHP Mailer updated to 5.2.14 in maintenance and development branches.
PHP Mailer is managed via composer in development branches (^5.2.14).