View Issue Details

IDProjectCategoryView StatusLast Update
0005896OXID eShop (all versions)4.03. 3rd party librariespublic2016-04-27 08:30
Reportergerldental 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.7 / 5.1.7 
Target VersionFixed in Version4.9.8 / 5.2.8 
Summary0005896: Deprecated: Function set_magic_quotes_runtime() is deprecated in ......./class.phpmailer.php on line 1350
DescriptionSeems to be, that the phpmailer library 5.0.2 ist not 100% with >= PHP 5.3 compatible. Library uses deprecated function set_magic_quotes_runtime(). Time for update? New version is 5.2.9.
Tags3rd Party Libraries
ThemeAzure
BrowserAll
PHP VersionNot defined
MySQL VersionNot defined

Relationships

related to 0004200 resolvedsaulius.stasiukaitis Update phpmailer to latest revision 
related to 0006314 acknowledgedflorian.auer Non endoded "Umlauts" in Email not working 

Activities

jurate.baseviciene

2014-10-13 10:33

reporter   ~0010229

Hi,
We are looking through all 3rd party libraries and evaluating them.
All changes will be presented with the Next Major Version.

Best regards

saulius.stasiukaitis

2016-03-15 11:01

reporter   ~0011497

PHP Mailer updated to 5.2.14 in maintenance and development branches.
PHP Mailer is managed via composer in development branches (^5.2.14).