View Issue Details

IDProjectCategoryView StatusLast Update
0005835OXID eShop (all versions)2.2. Shop settingspublic2014-07-25 09:15
Reporterjens.kintrup 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.8.6 / 5.1.6 
Target VersionFixed in Version 
Summary0005835: SMTP-Configuration - PHPMailer not RFC conform
DescriptionWe tried to configure the optivo SMTP-Host as an E-Mail Relay. This is a standard setting in the adminstrator backend of OXID. Sending E-Mail over strict SMTP-Relays is not possible due to a bug in the PHPMailer Version that is used by OXID CE or OXID EE. PHPMailer Version 5.0.0/5.0.2 is used within OXID to send emails, this version is 5 years old.

The PHPMailer sets an SMTP-Header "Return-Path", that is not allowed to use as a sender (MUA), see RFC-5321 section 4.4 for more details http://tools.ietf.org/html/rfc5321#section-4.4. This is known within PHPMailer, since more recent versions are conform and cause no trouble.

You can find the troublesome code in class.phpmailer.php (Version 5.0.2), lines 967 to 971:

if($this->Sender == '') {
  $result .= $this->HeaderLine('Return-Path', trim($this->From));
} else {
  $result .= $this->HeaderLine('Return-Path', trim($this->Sender));
}

The most recent version replaced this with:

/**
 * The Return-Path of the message.
 * If empty, it will be set to either From or Sender.
 * @type string
 * @deprecated Email senders should never set a return-path header;
 * it's the receiver's job (RFC5321 section 4.4), so this no longer does anything.
 * @link https://tools.ietf.org/html/rfc5321#section-4.4 RFC5321 reference
 */
public $ReturnPath = '';
Steps To ReproduceYou just need a strict SMTP-Host, that refuses the Return-Path Header in the SMTP-Protocol.
Additional InformationYou can fix this Bug simple with an update of PHPMailer, that is used within OXID.
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Versionany
Database Versionany

Relationships

duplicate of 0004200 resolvedsaulius.stasiukaitis Update phpmailer to latest revision 

Activities

FibreFoX

2014-07-24 13:42

reporter   ~0010032

Its already reported here: https://bugs.oxid-esales.com/view.php?id=4200

cesnauskast

2014-07-25 09:15

reporter   ~0010035

Closing this issue as duplicate of 4200