View Issue Details

IDProjectCategoryView StatusLast Update
0004130OXID eShop (all versions)2. ----- eShop backend (admin) -----public2012-11-14 15:09
Reporterdixeno 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0004130: Discount is calculated after editing old orders
DescriptionFor instance a customer purchased a basket with 3 positions/products.
After one week the the customer sent back one position/product.

During that week the admin started a discount over the whole shop.

If now the admin cancel that product, the other positions/products are recalculated with the discount which is now activated.

We found out that the discount is mentioned in version 4.5.9 in the separeted discount row. And in the version 4.6.1 the products are directly reduced in the price.
Steps To Reproduce1. purchase an order with more than one product
2. activate a discount
3. go to order administration and cancel one product of your order
4. compare the old price with new price
TagsNo tags attached.
ThemeBoth
BrowserFireFox 6.x
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0004624 acknowledged Order recalculation does not use discounts/taxes which were valid when order was made, but current ones 

Activities

dixeno

2012-06-06 17:52

reporter  

discount-row.png (12,812 bytes)
discount-row.png (12,812 bytes)

svetlana

2012-06-07 16:57

reporter   ~0006805

Reminder sent to: dixeno

Hi, thanks a lot for submitting this issue, but it is not a bug, because in eShop if you edit order in admin, order will be recalculated according new circumstances. If products prices were changed, order would be recalculated with new prices, discounts and etc.
Also in new 4.6.1 version the discount still is written in a separate line, unless discount is created with parameter "From:0"- then discount is applied directly on the product base price, so prices shown entirely in eShop are already reduced by that discount, but discount is not shown as special/separate discount in basket.

dixeno

2012-06-07 17:17

reporter   ~0006806

Thanks for the answer...

But it makes no sense to calculate old orders on new circumstances, because the customer bought products in old circumstances. So in my point of view a contract is enclosed in old circumstances and if the same customer wanna buy new products or send back some other products, then it should only effect that new product changes and not the other products, because the shop owner and customer has got still a contract under old circumstances for the other products.

Do you get my point?

ray

2012-07-22 17:45

reporter   ~0007121

Last edited: 2012-07-22 17:46

View 2 revisions

The point is, when updating payment date or shipping date for a particular order it is not necessary to recalculate the complete basket - especially when regarding only actual circumstances. Imagine a customer has placed an order with a special discount which is valid one week, he pays in advance via bank transfer. Then the shop owner receives the money two or three days later (after this special-discount-offer has been finished) and marks the order as payed - it will be recalculated without the discount.

So in my opinion a once placed order should never be recalculated based on actual discounts, prices or other circumstances - only with those which has been present while ordering. And it is absolutely not necessary to recalculate when only editing payment or shipment date. Why donĀ“t save all related things in oxorderarticles?

By the way - this one is related:
https://bugs.oxid-esales.com/view.php?id=4275

Kikix

2012-10-05 10:51

reporter   ~0007565

This one is related also:
https://bugs.oxid-esales.com/view.php?id=4574

When the shop has to recalculate an existing order it is nessesary to take the data out of oxorderarticles and NOT out of oxarticles!!!

ray

2012-11-09 07:57

reporter   ~0007786

and this one: https://bugs.oxid-esales.com/view.php?id=4677

Linas Kukulskis

2012-11-14 15:09

reporter   ~0007855

dublicated