View Issue Details

IDProjectCategoryView StatusLast Update
0004574OXID eShop (all versions)2. ----- eShop backend (admin) -----public2012-12-14 08:15
ReporterKikix 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version4.6.4 revision 49061 
Target VersionFixed in Version 
Summary0004574: price change in existing order
DescriptionIf I change the the price of an variant of an article and then press 'speichern' in the sheet 'Stamm' or 'Artikel' of an existing order (see ScreenShot) the price there will change. This is a but because the price at the time of the order is the right one!



Wenn ich bei einer Artikel-Variante den Preis ändere und dann bei einer abgeschlossenen Bestellung in der dieser Artikel vorkommt im Reiter Stamm auf "Speichern" drücke (siehe Screenshot), wird der geänderte Preis bei dieser Bestellung übernommen und die Bestellung wird somit nachträglich verändert. Das darf so nicht sein.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0004624 acknowledged Order recalculation does not use discounts/taxes which were valid when order was made, but current ones 

Activities

Kikix

2012-10-01 16:24

reporter  

ScreenShot.png (413,251 bytes)

dainius.bigelis

2012-10-01 17:11

reporter   ~0007519

Reminder sent to: Kikix

Hi,

This is not the issue. When there are some changes (changed prices, other discounts, etc.) comparing to the moment, when order was changed - then eShop recalculates all the estimation according to latest circumstances in the eShop.
There is no functionality in eShop, to store all the details of order, which were active at the order time. To implement that would be more a feature request.

Best regards,

Kikix

2012-10-02 10:11

reporter   ~0007523

Last edited: 2012-10-02 10:12

View 2 revisions

Hi,

when I for example want to make a 'Rabatt' or store a 'Tracking Code' to a existing order I have to klick 'Speichern'. When now the price of the article has changed in the shop this new price is then in the existing order. But my customer has to pay the price of the moment of the order and he already has paid this price when paid with PayPal or credit card! When I now print the invoice there is the wrong price on it.

The shop has to calculate with the price in oxorderarticles and not with the price of oxarticles!!!

The wrong handling of the shop has a bug in itself also. Look at Screenshot 80 before the pricechange ant to Screenshot 81 after. All prices are now the new prices exept OXPRICE. This is a double-bug ;)

Best regards

Kikix

2012-10-02 10:11

reporter  

ScreenShot 80.png (393,939 bytes)

Kikix

2012-10-02 10:11

reporter  

ScreenShot 81.png (330,404 bytes)

leofonic

2012-10-02 12:38

reporter   ~0007525

Related to 0004130

Linas Kukulskis

2012-11-14 15:08

reporter   ~0007854

dublicate