View Issue Details

IDProjectCategoryView StatusLast Update
0004677OXID eShop (all versions)2. ----- eShop backend (admin) -----public2012-11-09 10:35
ReporterMIB 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version4.6.2 revision 46646 
Target VersionFixed in Version 
Summary0004677: Article prices being updated if some unrelated change is made to an order (EE)
DescriptionThe price of an item in a order will be updated to the current value if changes are made to an order like entering the invoice number or adding/deleting another item to an order.

Steps To Reproduce1. Make a test order including at least two different items
2. change the price of one item included in the test order after that order has been completed
3. Log into Admin and locate the order
4. Make a change to the order ie. entering an invoice number or add/delete the other item from the order that has not been changed

You will notice that the price for the item that had the price changed after ordering now reflects the changed price and not the price the customer saw while ordering which ma result in legal trouble.
Additional InformationProblem can be reproduced in Enterprise version 4.6.2 as well as well in current Enterprise revision 4.6.5. Is also reproducable in the Oxid Enterprise demo installation.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0004624 acknowledged Order recalculation does not use discounts/taxes which were valid when order was made, but current ones 

Activities

MIB

2012-11-08 17:36

reporter   ~0007783

If this is duplicate, would you be so kind to provide the ticket number for the actual ticket for reference?

ray

2012-11-09 07:54

reporter   ~0007785

related to this one: https://bugs.oxid-esales.com/view.php?id=4275
there are more related issues mentioned there

All those issues happen due to the recalculation logic on saving changes in an already existing order.