View Issue Details

IDProjectCategoryView StatusLast Update
0003297OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2012-12-07 14:28
Reporterd3 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version4.5.1 revision 38045 
Target VersionFixed in Version 
Summary0003297: incorrect comparison: $oDetailsProduct->getFTPrice() > $oDetailsProduct->getFPrice()
Descriptionin template page/details/inc/productmain.tpl:

this works not correct:
[{if $oDetailsProduct->getFTPrice() > $oDetailsProduct->getFPrice()}]

course $oDetailsProduct->getFTPrice() and $oDetailsProduct->getFPrice() return values with comma like

100,85 > 95,81 (95,81 is bigger as 100,85, if compared as string)
59,20 > 56,24 (this works ;-) )

Additional Informationin relation with ticket: 0002874
TagsProducts
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Relationships

duplicate of 0003154 resolvedLinas Kukulskis Wrong comparision in listitem_line.tpl 

Activities

csimon

2011-11-11 15:34

reporter   ~0005380

This is the same bug as https://bugs.oxid-esales.com/view.php?id=3154. Seems it wasn't fixed in all files.

However: This is not a minor bug, because the whole template behavior for tprices is relying more or less on lucky coincidences.

dainius.bigelis

2012-02-29 16:21

reporter   ~0005845

Marked this as duplicate of 3154. Set this entry as High priority