View Issue Details

IDProjectCategoryView StatusLast Update
0002666OXID eShop (all versions)6. ------ Setup -------public2012-05-23 15:20
Reportermarco_steinhaeuser 
PriorityurgentSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.4.8 revision 34028 
Target VersionFixed in Version4.5.7 revision 41909 
Summary0002666: Setup stops because of a pretended wrong PHP module for MySQL 5
DescriptionFound in this forum (German):
http://forum.bplaced.net/viewtopic.php?f=10&t=18501&p=329853

System health check shows a red button while checking for an appropriate PHP module for MySQL 5. The provider uses the most recent MySQL Native Driver that has no version number in his name.

Read more about it:
http://dev.mysql.com/downloads/connector/php-mysqlnd/
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Relationships

related to 0001758 resolvedvilma_liorensaityte If mysqlnd driver is installed mark it as "green" 

Activities

Linas Kukulskis

2011-07-01 16:07

reporter   ~0004811

Reminder sent to: marco_steinhaeuser

To solve this bug I need more info: what was mysql version and what connector was used.
I checked we are checking this native mysql driver - mysqlnd, so everything seems ok, maybe mysql version was wrong.

Linas Kukulskis

2011-07-11 10:40

reporter   ~0004845

need more info.
when info comes reopen the bug.

marco_steinhaeuser

2011-11-23 15:54

administrator   ~0005439

Hi Linas,

sorry - I will miss every reminder. Best to ping me by Skype in this cases.
Have some more information here. In this thread, the hoster's support explains that they use mysqlnd instead of libmysql which might provoke the unwanted behaviour.
https://www.oxid-esales.com/forum/showthread.php?t=3397

Here, you'll find a phpinfo:
phpinfo.bplaced.net

Hope, you'll find enough :-)

Linas Kukulskis

2011-12-12 09:41

reporter   ~0005471

moved extension check from versions check version part to extension check part

marco_steinhaeuser

2012-01-02 11:04

administrator   ~0005572

From the forums I heard that it now, after the fix, doesn't work in other environments, e.g. on the present XAMPP version:
http://www.oxid-esales.com/forum/showthread.php?t=12729&page=2#post77784

Couldn't reproduce it on
PHP Version 5.3.6-13ubuntu3.3
Server: Localhost via UNIX socket
Server version: 5.1.58-1ubuntu1, same PHP client version

Linas Kukulskis

2012-01-04 15:15

reporter   ~0005579

removed bad fix.
after some more investigation it seems that problem is with hosting provider.
our system health check on mysql native driver expects that function mysql_get_client_info() returns ".. mysqlnd ...", but in phpinfo.bplaced.net
phpinfo shows "MySql native drive" its seems unusual.

so if we can check what is returned on mysql_get_client_info() call on bplaced.net server it would help us.

please reopen this bug when this information is known.