View Issue Details

IDProjectCategoryView StatusLast Update
0000746OXID eShop (all versions)4.07. Source code, Testpublic2012-12-10 13:45
Reportertjungcl 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.0.1.0 revision 15990 
Target VersionFixed in Version 
Summary0000746: iso-...1 (latin1) ==> iso-...15 (latin9) : Mysql Database ist still latin1
DescriptionI know, you are working on utf-8 (i'm really looking forward to :-) ), so it might become irrelevant, but:

The database saves all data in iso-...1, while the shop displays data in iso-...15. This is a problem with a few signs like "1/2" or "Euro".
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
Database Version5.0.33

Relationships

duplicate of 0000579 resolvedarvydas_vapsva Currency signs are displayed incorrectly after Save of Core settings, what leads to corruption 

Activities

dainius.bigelis

2009-03-26 16:53

reporter   ~0000642

Reminder sent to: tjungcl

Hi,

This problem occured some time ago after 4.0.1.0 release (see bug entry 0000579). Now these values are re-encoded from ISO-8859-1 to ISO-8859-15 and now it works fine. The fixed values will be included in the next release.
As workaround would work - if you would save the correct value in the DB, or i.e. for EUR sign - you can insert correct value in the currencies field in Admin and this will be displayed correctly in frontend.

Best regards,

dainius.bigelis

2009-03-26 16:53

reporter   ~0000643

Duplicate of 0000579