View Issue Details

IDProjectCategoryView StatusLast Update
0000579OXID eShop (all versions)2.1. Master Settingspublic2012-12-10 16:31
Reporterdainius.bigelis 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.0.1.0 revision 15990 
Target VersionFixed in Version4.1.0 revision 17976 
Summary0000579: Currency signs are displayed incorrectly after Save of Core settings, what leads to corruption
DescriptionIn Admin area => Corre Settings => Settings (shop_config.php) after each Save (even if there are no changes made for options) the currency signs are displayed incorrectly.

Looks like in DB the char is saved correctly, but the problem is in the loading and displaying char in Admin area. Means, when you save € sign in Admin, it is displayed as € in frontend, but in Admin it is already displayed as ¤.
But if you will save Admin options then with ¤ (then it is written to DB), this will be displayed in frontend as ¤, and in Admin it is shown as &curren.
The next Saves may lead to further corruptions, like "à ¢ï¿½à ¬", etc.
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
Database Version5.0.33

Relationships

has duplicate 0000746 closed iso-...1 (latin1) ==> iso-...15 (latin9) : Mysql Database ist still latin1 

Activities

arvydas_vapsva

2009-02-13 14:54

reporter   ~0000433

same for SEO information

arvydas_vapsva

2009-02-18 12:13

reporter   ~0000439

currencies were broken due to different encoding - most setting were saved in ISO-..-1, currency array was saved in windows-1252 charset long time ago ...

Recoded values and everything is fine now